Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Определить время прибытия с учетом условия (не меньше указанного времени)
 
В моей таблице имеется несколько времени в формате 00:00 ч мм. И мне нужно сравнить с определенным временем и делаю это формулой =МИН(ЕСЛИ(B15<C4:C13;C4:C13;0)). Но в ячейке я получаю ошибку
#ЗНАЧ!
Что делать? как обойти эту тему?
 
Deagle3, А файл пример покажите
а без примера возможно формулу нужно вводить CTRL+SHIFT+ENTER
Изменено: Mershik - 28 ноя 2018 21:22:33
Не бойтесь совершенства. Вам его не достичь.
 
Вот, он мне должен выдать овтет 11:49
Изменено: Deagle3 - 28 ноя 2018 21:27:48
 
=МИН(ЕСЛИ(B15<C4:C13;C4:C13))
Цитата
Mershik написал:
CTRL+SHIFT+ENTER
 
1. Формула массива вводится  тремя клавишами
2. Ищете минимальное между времени, определяемому условием, и нулем. Что в итоге получите?
 
Mershik прав  нужно вводить тремя кнопками, ну и убрать ;0 или заменить на ;9^9, иначе минимум будет 0
По вопросам из тем форума, личку не читаю.
 
Цитата
Catboyun написал:
Mershik  написал:CTRL+SHIFT+ENTER
Пробовал, выдает 0
 
Цитата
vikttur написал:
Ищете минимальное между времени, определяемому условием, и нулем. Что в итоге получите?
В смысле? я же задаю условие,что моя ячейка должна быть меньше диапазона,если да, то выдать минимальное,если нет то 0. Но он всегда выдает ноль
 
Смотрите #6
Цитата
БМВ написал:
убрать ;0 или заменить на ;9^9, иначе минимум будет 0
Не бойтесь совершенства. Вам его не достичь.
 
Даже #4
По вопросам из тем форума, личку не читаю.
 
обычная
=ИНДЕКС(C4:C13;ПОИСКПОЗ(B15;C4:C13)+1)
для Вашей таблицы, где время упорядочено по возрастанию и <, а не <= подойдет.

файл из сооб.№4 смотрели?
 
А можете объяснить для чего +1?, если использовать эту формулу, то такой же ответ получается, я даже теперь не знаю какуюформулу вводить  
 
А можно еще сразу спросить, как записать формулу?
У меня получилось 11:49, теперь мне нужно из таблицы взять время прибытия, то есть 12:09.
Это лучше делать через двссыл?
 
Цитата
Deagle3 написал: я даже теперь не знаю
массивная более универсальная.
Цитата
Deagle3 написал: для чего +1?
неточный ПОИСКПОЗ найдет число меньшее (наиболее близкое) или равное (если такое есть) к искомому,
а Вам надо число больше, значит следующее за найденным = +1.
если число не будет найдено формула выдаст ошибку, так вернее:
=ЕСЛИОШИБКА(ИНДЕКС(C4:C13;ПОИСКПОЗ(B15;C4:C13)+1);0)
но неточный поиск корректно работает только в упорядоченном диапазоне.
 
Замените второй диапазон в показанной ранее формуле
Или немассивно:
=ИНДЕКС(D4:D13;ПОИСКПОЗ(B15;C4:C13)+1-СЧЁТЕСЛИ(C4:C13;B15))
 
Все получилось. Спасибо всем))  
Изменено: Deagle3 - 28 ноя 2018 22:19:26
Страницы: 1
Читают тему (гостей: 1)
Наверх