Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Список уникальных (не повторяющихся значений) формулой
 
Нашел формулу тут, пытаюсь адаптировать для своей таблицы. Почему не работает?
 
BRETER, добрый день,
Код
 =ЕСЛИОШИБКА(ИНДЕКС($B$1110:$B$2209;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($C$1109:C1109;$B$1110:$B$2209)=0;СТРОКА($B$1110:$B$2209)-1109);1));"")

и еще вариант НЕ массивная.

Код
=ЕСЛИОШИБКА(ИНДЕКС($B$1110:$B$2209;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ($C$1109:C1109;$B$1110:$B$2209)=0)/($B$1109:$B$2209<>"");0);0));"")
Изменено: Mershik - 29 Ноя 2018 10:35:05
 
Цитата
Mershik написал:
вариант НЕ массивная
Спасибо! именно ее решил применять.
 
Mershik, предложил рабочий вариант, но к сожалению на нескольких тысячах позиций жуткие тормоза.
В итоге поискал получше и выяснил, что автор ресурса уже о нас позаботился :) . Способ 3. Выборка уникальных записей формулой - использую его и всем рекомендую.
Страницы: 1
Читают тему (гостей: 1)
Наверх