Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Разделить текст по столбцам(содержание и наименования разные)
 
Здравствуйте! Необходимо разделить текст по столбцам, по определенным данным и наименованиям. Наименование одно, содержания разные. Исправить может формулу  или макрос? Заранее благодарю.
 
Упростите.
Для каждого столбца отдельную формулу с поиском нужного  фрагмента
=ЕСЛИ(ЕЧИСЛО(ПОИСК("ул.";A2));...
с очисткойт правой части. Например
=ЕСЛИ(ЕЧИСЛО(ПОИСК("ул.";A2));СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПСТР(A2;ПОИСК("ул.";A2)+3;99);",";ПОВТОР(" ";99));99));"")
 
А с домом и кв так же? И нужно чтобы была "ул."?
 
http://www.planetaexcel.ru/forum/index.php?PAGE_NAME=message&TID=84380
https://www.planetaexcel.ru/forum/index.php?PAGE_NAME=read&FID=1&TID=101044
 
Цитата
Kuzmich написал:
http://www.planetaexcel.ru/forum/index.php?PAGE_NAME=message&TID=84380  https://www.planetaexcel.ru/forum/index.php?PAGE_NAME=read&FID=1&TID=101044
Не подходить?
 
Alexfaa, вам vikttur уже все дал
 
Цитата
artyrH написал:
Alexfaa , вам  vikttur  уже все дал
Спасибо большое не обратил внимание  
Страницы: 1
Читают тему (гостей: 1)
Наверх