Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Корректировка формулы поиска по двум условиям
 
Всем привет. Помогите скорректировать формулу для поиска по нескольким условиям. Есть отчет по покупателям, нужно найти значение в столбце итог по 2м условиям:
1 находит контракт (например Арнест ОАО)
2 в этом же контракте Арнест ОАО находит магазин например Иродов Григорий Автономович ИП и выводит его значение из столбца итог.
Код
 ВПР(B20;ПОИСКПОЗ(B10;B10:B222;0):F222;5;ЛОЖЬ)
пробовал такую ничего не выходит.
 
Код
=ВПР("Иродов Григорий Автономович ИП";ИНДЕКС($B$1:$F$206;ПОИСКПОЗ("Арнест ОАО";$B$1:$B$206;0);):$F$206;СТОЛБЕЦ(B10);ЛОЖЬ)
Изменено: artyrH - 1 Дек 2018 07:37:13
 
не прокатит если нет такого магазина в этом контракте. просто возьмет значение из другого (следующего) контракта.
предыдущая формула, кстати, тоже
Изменено: VideoAlex - 1 Дек 2018 07:46:31
 
artyrH, спасибо все работает)))
 
Madmax, подождите. моя формула не работает, если в выбранном контракте нет искомого ипешника. если есть ипэ в следующих контрактах, то данные будут оттуда. если контракты и магазины связаны, то все ok.
успели прочитать?
Изменено: artyrH - 1 Дек 2018 07:58:56
 
небольшой совет по организации данных, вашей таблице нужен еще один столбец с названием контракта для каждого ип
Скрытый текст

Тогда всё здорово организуется и фильтрами и сводными и находить всё можно элементарными формулами
Изменено: VideoAlex - 1 Дек 2018 08:16:05
 
добавил единицы напротив контрактов
Страницы: 1
Читают тему (гостей: 1)
Наверх