Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Циклический график дежурств в зависимости от даты
 
Здравствуйте, форумчане!
У меня появилась загвоздка в решении вроде бы и несложной задачи. Если вы мне поможете, то буду вам очень признательна.

Есть график дежурств. Есть цикл -12 дней. То есть через 12 дней этот цикл повторится. Как будет выглядеть формула в ячейках? Понимаю что это как то связано с функцией ДАТАЗНАЧ, но не получается правильно написать формулу.

В примере как это должно выглядеть. На втором листе мои тщетные попытки воплотить идею.
 
дальше сами
 
работает! но формула такая, я бы не додумалась так сделать)) спасибо!
 
Начало графика как задается? С какого значения начинать?
=ВЫБОР(ОСТАТ(СТОЛБЕЦ(A1);12)+1;"b";"21-6";"21-6";"21-6";"21-6";"b";"b";"20-5";"20-5";"20-5";"20-5";"b")
Смещение задавать столбцом

С таблицей соответствий
=ВПР(ОСТАТ(СТОЛБЕЦ(A2);12)+1;Лист1!$A$14:$B$25;2;)
 
Цитата
vikttur написал:
Начало графика как задается? С какого значения начинать?
зависит от даты в  B9
 
Код
=ВПР(ОСТАТ(E$11-43375+$D12*4;12);Д;2)
в С11 пишете начальную дату
отмечаете Е11:Е14
за правій нижний уголок тянете вправо, сколько сил хватит
(начальную дату в последующем можете менять когда угодно и сколько угодно раз)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Страницы: 1
Читают тему (гостей: 1)
Наверх