Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск-замена цены
 
Прошу подсказать, как можно заменить значение цены на вот такой формат?
В ячейке A1 расположена цена, например 3000 или 55000 (и.т.п). В ячейке A2 нужно получить ту же цену, только после нее еще и вертикальную черту и опять ту же цену. Т.е. будет вид такой (выделено зеленым и жирным)
былостало
30003000|3000
5500055000|55000
55000|11000055000|110000
1000|50001000|5000
от 55000от 55000
до 6000до 6000
Также в столбце с ценами есть куча всего лишнего, в примере выше я эти значения вставил - их нужно просто игнорировать формулой.
Данное извращение нужно для импорта в CMS, уж слишком корявый импортер на сайте - воспринимает только диапазоны, нельзя указать точную цену.
 
Код
=ЕСЛИ(ЕЧИСЛО(A2);A2&"|"&A2;A2)
Согласие есть продукт при полном непротивлении сторон.
 
@Sanja, спасибо огромное! Именно то что нужно!
Страницы: 1
Читают тему (гостей: 1)
Наверх