Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вывести цену товара за последний приход..., Цена товара
 
Здравствуйте,

Столкнулся с такой задачей. Надо вывести цену товара на каждую модель и за последний приход. Звучит скромно, но решить не могу. :(  Помогите!
Изменено: Шахин - 4 Дек 2018 11:03:56
 
Шахин, добрый день,  если последние даты всегда в конце списка.
Код
=ПРОСМОТР(2;1/(([@[Product Name]]=Приход!$B:$B)*(Приход!$C:$C=[@Model]));Приход!$D:$D)
Изменено: Mershik - 4 Дек 2018 11:17:43
 
Mershik, Спасибо! А можно в файле что я прикрепил?) ;)  
 
период имеет начало и конец периода. Где у вас начала и концы периодов?
 
Михаил Лебедев, Период мне не обязателен. Просто надо вывести цену за последний приход для каждой модели. Вчера это может быть 5 рублей, а сегодня 4.
 
последний приход может быть центре таблицы?
 
Упс... Слепой стал... Приход прочитал как период... Сорри...
Вот с доп. столбцом.
 
=СУММЕСЛИМН(Приход!D:D;Приход!B:B;A3;Приход!C:C;B3;Приход!A:A;МИН(Приход!A3:A1028))
 
Anton555,Нет, тут у вас показывает минимальное значение.
 
Михаил Лебедев,Спасибо! ) Хоть как то!)
 
да, прочитал вместо максимального - минимальное значение
вот формула без каких-либо допстолбцов -
=ЕСЛИОШИБКА(ВПР(МАКСЕСЛИ(Приход!A:A;Приход!B:B;[@[Product Name]];Приход!C:C;[@Model]);Приход!A:D;4;0);"")
Изменено: Anton555 - 4 Дек 2018 14:54:58
 
Anton555, Супер!)) Спасибо!) :D  
Изменено: Шахин - 4 Дек 2018 15:07:48
Страницы: 1
Читают тему (гостей: 1)
Наверх