Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Проверка одного массива на наличие в нем значений другого массива + добавление значения
 

Добрый день, нужно решить такую задачу:  в столбец D забиваем телефоны, и если есть совпадения по ним в стобце А, то выводим результат в столбец F и  при этом нужно подтянуть данные из столбца B либо в рядом стоящий столбец, либо совместить всё в одной ячейке.   (Столбец А и B изначально будут в таком формате - телефон в одном столбце, а статус в следующем)  Спасибо.
 
Цитата
david_sash написал: нужно решить такую задачу
Приступайте - расширенный фильтр вам в подмогу... :)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
В столбце F пишем следующую формулу и тянем вниз:
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(D2;$A$2:$A$9;0));"нет в списке";D2)

В столбце G:
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$9;ПОИСКПОЗ(F2;$A$2:$A$9;0));"")
Изменено: Maruf - 4 Дек 2018 14:08:16
No crime is so great as daring to Excel. (Winston Churchill)
 
Спасибо, столбец F заработало, столбец G просто пустые ячейки выбивает.
 
вариант в файле
Лень двигатель прогресса, доказано!!!
 
Sorry. Исправьте во второй формуле I2 на F2
No crime is so great as daring to Excel. (Winston Churchill)
 
Спасибо всем, то что нужно!
Страницы: 1
Читают тему (гостей: 1)
Наверх