Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Адаптиповать СУММПРОИЗВ для использования в VBA
 
Доброго времени суток, уважаемые форумчане. Подскажите, пожалуйста, как можно решить данный вопрос. Требуется вычислить значение, для чего используется формула СУММПРОИЗВ (ячейка В10):
Код
=СУММПРОИЗВ((H2:H7*J2:J7)*(C2:C7="23.06.2018")*(B2:B7="Петрова"))
Все вычисляется правильно. А вот как получить этот же результат, используя Application.SumProduct в коде VBA? Попробовал использовать следующую конструкцию:
Код
[C10] = Application.SumProduct((Range("H2:H7") * Range("J2:J7")), (Range("C2:C7") = "23.06.2018"), (Range("B2:B7") = "Петрова"))
но не вышло, ошибка 13 Type mismatch. Что сейчас не так написано в коде?
P.S. Вариант с дополнительным столбцом (с суммой)  и использованием SumIfs не подойдет, если вариант с SumProduct не реален, то не страшно, вычислю по иному
 
Код
.[C10] = Application.Evaluate("SumProduct((H2:H7 * J2:J7) * (C2:C7 = ""23.06.2018"") * (B2:B7 = ""Петрова""))")
Изменено: JayBhagavan - 4 Дек 2018 17:18:06

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
Без формулы жизни не будет? Почему вычисления не перенести в VBA?
Страницы: 1
Читают тему (гостей: 1)
Наверх