Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Заполнение таблицы данными из 4х таблиц с условием
 
Добрый день всем!
Нужно найти значение нормы, которое выбирается в зависимости от введенных значений массы и длины из таблиц определенного цвета (цвет указывает вид сопряжения для наглядности). Как выполняется выбор определенного числа из одной таблицы подсказал БМВ в теме ТУТ
 
Sergo727,  чет не понятно в какой из 4х искать?  покажите конечный результат
Изменено: Mershik - 4 Дек 2018 17:03:14
 
Допустим,  указываем профиль - 120, длина - 2,5, как в примере, присвоив видам сопряжения цифровые обозначения 1- по одному торцу (красная таблица), 2 - по двум торцам (зеленая таблица), 3 - в трёх четырёх местах (синяя), 4 - по всей длине (фиолетовая). При указании в столбце - вид сопряжения цифру 1, должно отобразиться значение - 2,65, цифру 2 -3,46, 3 - 3,68, 4 - 4,07
 
Как вариант - вот это должно работать

Исправил. Теперь выдаёт верный результат.
Изменено: Wiss - 5 Дек 2018 09:28:51
Я не волшебник, я только учусь.
 
Sergo727, вариант такой пока только для четверной таблицы...
чуть изменил табличку  исходную (вместо кол-ва углов написал 1, 2, 3, 4)

ИЗМЕНИЛ ОШИБКА БЫЛА
Код
=ИНДЕКС(ИНДЕКС($B:$B;ПОИСКПОЗ($S5;$K:$K;0)+1;1):ИНДЕКС($A:$J;ПОИСКПОЗ($S5;$K:$K;0)+ЕСЛИ(ИЛИ($S5=1;$S5=2;$S5=3);7;9);10);ЕСЛИ(ИНДЕКС(ИНДЕКС($A:$A;ПОИСКПОЗ($S5;$K:$K;0)+1;1):ИНДЕКС($A:$A;ПОИСКПОЗ($S5;$K:$K;0)+ЕСЛИ(ИЛИ($S5=1;$S5=2;$S5=3);7;9);1);ПОИСКПОЗ($R5;ИНДЕКС($A:$A;ПОИСКПОЗ($S5;$K:$K;0)+1;1):ИНДЕКС($A:$A;ПОИСКПОЗ($S5;$K:$K;0)+ЕСЛИ(ИЛИ($S5=1;$S5=2;$S5=3);7;9);1);1);1)<$R5;ПОИСКПОЗ($R5;ИНДЕКС($A:$A;ПОИСКПОЗ($S5;$K:$K;0)+1;1):ИНДЕКС($A:$A;ПОИСКПОЗ($S5;$K:$K;0)+ЕСЛИ(ИЛИ($S5=1;$S5=2;$S5=3);7;9);1);1)+1;ПОИСКПОЗ($R5;ИНДЕКС($A:$A;ПОИСКПОЗ($S5;$K:$K;0)+1;1):ИНДЕКС($A:$A;ПОИСКПОЗ($S5;$K:$K;0)+ЕСЛИ(ИЛИ($S5=1;$S5=2;$S5=3);7;9);1);0));ЕСЛИ(ИНДЕКС($B$2:$J$2;1;ПОИСКПОЗ($Q5;$B$2:$J$2;1))<$Q5;ПОИСКПОЗ($Q5;$B$2:$J$2;1)+1;ПОИСКПОЗ($Q5;$B$2:$J$2;0)))
Изменено: Mershik - 4 Дек 2018 18:13:39
 
Wiss, спасибо, но показывает не те значения, верное значение всегда расположено ниже и правее на 1 строку

Mershik гениально, все работает, спасибо!!!!
 
Ещё один любитель цитирования...
Sergo727,  кнопка цитирования не для ответа!
Страницы: 1
Читают тему (гостей: 1)
Наверх