Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск определённого слова в ячейке PQ, В каждой ячейке определенного столбца нужно найти определенное слово.
 
Выгрузил здоровенную таблицу в PQ, для дальнейшей обработки. Столкнулся с проблемой поиска части текста.
Суть:
Есть столбец с названиями деталей для машины, нужно создать соседний столбик, который проверит ячейку с деталями на наличие одного или другого слова в названии, и если хоть какое-то из них там есть, то во втором напишет, например "1", а если нет то "0". По типу =ЕСЛИ(ЕЧИСЛО(ПОИСК("слово";A1));"1";"0")
Подскажите, пожалуйста есть ли возможность это сделать, и какой функцией(формулой)? И было бы прям великолепно не в расширенный редактор формулу записывать, а в окошко "Пользовательская формула столбца" при его создании.

Если похожая тема существует, прошу извинить, возможно неверно запрос в поиске написал, но не нашел.

Заранее спасибо.
Изменено: multsib - 5 Дек 2018 00:40:40
 
Цитата
multsib написал:
В каждой ячейке определенного столбца нужно найти определенное слово
Я нашел как это сделать:
При создании нового пользовательского столбца пишем:
Код
=if Text.Contains([Column1], “слово“)
then “Есть“ else “Нет“

Либо при создании столбца выбираем "Условный столбец" и вносим данные:

[P]
Изменено: multsib - 5 Дек 2018 09:27:12
Страницы: 1
Читают тему (гостей: 1)
Наверх