Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск слова в тексте и по этому слову подтягивать значение(Если имеется)
 
Господа, добрый вечер.

Не могу сообразить как можно сделать такую вещь
Есть лист с ячейками такого плана:
Цитата
GiGwi игрушка для   кошек Мышка с электронным чипом
игрушка для кошек Мышка гигви с   электронным чипом
На втором листе есть таблица со словами такого плана:
Цитата
ГиГвиGiGwiГиГви (GiGwi)
Нужно в ячейке на листе1 найти слово из листа2(А1 или B1) и если оно найдется, то в ячейку где формула вставить в таком формате как на листе2 в ячейке C1(ГиГви (GiGwi))

Т.е. условно просто найти слово в ячейке и если оно есть сВПРить. Сам прийти к решению не могу, поиск тоже не дал результатов. VBA не знаю.
 
=ЕСЛИОШИБКА(ИНДЕКС(Таблица!$C$1:$C$2;АГРЕГАТ(15;6;СТРОКА(Таблица!$C$1:$C$2)/ЕЧИСЛО(ПОИСКПОЗ("*"&Таблица!$A$1:$B$2&"*";$A2;0));1));"")

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
Спасибо большое, возьму на заметку и попробую разобраться :)
Хорошего Вам дня.
Страницы: 1
Читают тему (гостей: 1)
Наверх