Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Протяжка формулы по горизонтали: суммирование через столбец
 
Добрый день! Полазил по форуму, но так и не смог найти ответ на свой вопрос. Необходимо протянуть формулу (=СУММ(A1:A10;G11)) по горизонтали, при этом формула должна считать определенные столбцы (столбцы помеченные красным цветом должны пропускаться) . Файл с примером прикладываю.
 
Непонятно. Вернитесь, добавьте в пример желаемый результат.
Критерий - только цвет? Шапки таблицы никакой нет?
 
Если правилно понял:
=СУММ(A1:A10*ОСТАТ(СТОЛБЕЦ(A1);2);G11)
Формула массива.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Попробую более подробно описать желаемый результат. Ячейка I5 это (=СУММ(I1:I4)), ячейка I6 это (=СУММ(A1:A5)+I5), но необходимо задать формулу для ячейки I6 так, чтобы при протяжке формулы в ячейке I6 была формула - (ячейка I5+СУММ(A1:A5)), в ячейке J6 была формула  (ячейка J5+СУММ(С1:С5)), в ячейке К6 была формула  (ячейка К5+СУММ(E1:E5)), столбцы B,D, F считать не надо, пропускаются. Файл с примером немного поменял. Надеюсь, теперь понятно смог изложить свое пожелание ))).
 
=СУММ(I5;ИНДЕКС($A$1:$F$5;;СТОЛБЕЦ(A1)*2-1))
 
Урра получилось, спасибо большое за помощь!!!!  
Страницы: 1
Читают тему (гостей: 1)
Наверх