Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Добавить столбец, сцепить, найти и вернуть значение со всеми слобцами
 
Всем привет , кто может подсказать решение , vba

В файле есть 3-и листа.
1) Devision - то , что нужно обработать
2) Leg- тут хранится база
3) RESULT - этот лист для примера как должно выглядеть после макроса.

Цепочка действий :
1) Добавить пустой столбец ( в него надо подтянуть значение из листа Leg )
2) Что бы понятнее объяснить , в пустом столбце , должна быть формула типа :/Сцепить devision1 и Leg1523/ найти это на листе Leg и вернуть значение из второго столбца/
3)Повторить эту формулу для всех значений из первого столбца
4) Закончив с первым столбцом , проделать то же самое со следющими.

В файле все есть,только таких столбцов может быть >100
Возможно любое ваше решение.  Спасибо заранее.
 
добавляем столбец ручками и вставляем формулу, растягиваем.
Код
=ВПР($A$1&A2;Leg!$A$1:$B$27;2;)

подойдет?
 
Проверяйте макрос:
p.s. Нужно бы добавить еще проверку на ошибки, если не найдено значение, но наверное  это уже вопрос для другой темы
Изменено: _Igor_61 - 5 Дек 2018 21:27:23
 
V, Привет , нет , потому тчо таких столбцов будет > 1800

_Igor_61, Здравствуйте .Спасибо за помощь.
Но, если на листе LEG отсоветует значение , то макрос останавливается с ошибкой.
Пример во вложении. Нажимаю кнопку и ошибка.  
 
Max.il,
Цитата
_Igor_61 в #3 написал:
p.s. Нужно бы добавить еще проверку на ошибки, если не найдено значение, но наверное  это уже вопрос для другой темы
поскольку эта тема:
Цитата
Добавить столбец, сцепить, найти и вернуть значение со всеми слобцами
Вот смотрите:
1.допустим, на листе "Divesion" есть какое-то значение, а на листе "Leg" этого значения нет
2.напротив: на листе "Leg" есть какое-то значение, а на листе "Divesion" этого значения нет
3 и 4: пустые ячейки в обрабатываемых столбцах и на том и на другом листе - могут быть?
5.Какие еще ошибки нужно предусмотреть в конечном коде? Текст, цифры, кириллица или латиница и т.д.?
Вот Вам и отдельная тема - в полном соответствии с Правилами форума, хотя и так в Вашей теме уже несколько задач (даже в названии самой темы - добавить, сцепить, найти, вернуть...) - я и так уже за свой ответ в этой теме вполне заслужил законный гнев модераторов.
P.S. Только что увидел: в #1 столбцов >100, в #4 уже > 1800  
Max.il, это существенно для скорости работы макроса, особенно если и строк тоже много.
Продумайте хорошенько в комплексе свою задачу, если нужно - разбейте на отдельные вопросы, и Вам обязательно здесь помогут.  
Изменено: _Igor_61 - 6 Дек 2018 17:32:41
Страницы: 1
Читают тему (гостей: 1)
Наверх