Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сумма по нескольким критериям в одной ячейке
 
Добрый день. Маюсь над задачей из одной таблицы выдернуть данные в другую по условиям. Делаю обычно формулой Суммесли (Суммеслимн), но иногда в большом массиве данных попадаются такие строки где несколько условий в одной ячейке. Для понимания скриншот http://prntscr.com/lrgnrd. Данные из Таблицы 2 в Таблицу 1.
Изменено: big-ivan - 6 Дек 2018 14:41:35
 
=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК($I$3:$I$18;B3))*$J$3:$J$18)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
еще вариант с доп таблицей ведения договоров/индексов
Код
=СУММПРОИЗВ(СУММЕСЛИ($I$3:$I$18;ИНДЕКС($Q$3:$Q$12;ПОИСКПОЗ(A3;$P$3:$P$12;0)):ИНДЕКС($Q$3:$U$12;ПОИСКПОЗ(A3;$P$3:$P$12;0);ПОИСКПОЗ(9^9;ИНДЕКС($Q$3:$U$12;ПОИСКПОЗ(A3;$P$3:$P$12;0););1));$J$3:$J$18))
Лень двигатель прогресса, доказано!!!
 
Вариант:
=СУММ(ЕСЛИ(ЕОШИБКА(ПОИСК(" "&$I$3:$I$18&" ";" "&ПОДСТАВИТЬ(B3;",";" ")&" "));0;$J$3:$J$18))

Bema, для чисел больше 9 ваш вариант не работает - например в 10 найдет и 10 и 1
Изменено: buchlotnik - 6 Дек 2018 16:51:01
Каждому For свой Next
Страницы: 1
Читают тему (гостей: 1)
Наверх