Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Power Query. Суммирование по условию в запросе на языке M.
 
Подскажите пожалуйста, как в Power Query написать формулы которые считают
Количество вхождений конкретного значения в столбце, выше текущей строки
Сумму значений в столбце, выше текущей строки,  при выполнении условия.
В экселе я это реализую  вот так
Код
=СЧЁТЕСЛИ($A$1:A2;[@Имя])
=СУММЕСЛИ($A$1:A2;[@Имя];$B$1:B2)

Столбец [Имя] это столбец А
 
Вот так.
Для модераторов тема:Power Query. Суммирование по условию в запросе на языке M.
Изменено: PooHkrd - 7 Дек 2018 09:22:31
 
Как я понял там считают по всей таблице. А мне надо только до текущей строки.
 
Пронумеровать строки и найти решение здесь можно: СУММЕСЛИМН в Power Query
Изменено: vlad000 - 9 Дек 2018 15:47:07
 
Baho, как это сделать приведено в примере в моём ответе на ваш вопрос про List.Generate. То что вы хотите называется накопительная или кумулятивная сумма. В бух учете есть такой термин 'Сумма накопительным итогом'.
Изменено: PooHkrd - 9 Дек 2018 15:43:13
Страницы: 1
Читают тему (гостей: 4)
Наверх