Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Нарастающая сумма элементов массива
 
Здравствуйте уважаемые форумчане.
Возникла необходимость в формуле, которая вернёт массив нарастающих сумм элементов одномерного массива.
Т.е. есть вертикальный массив {8:2:5:3:6}. Необходимо формулой получить такое {8:10:15:18:24}
Честно говоря нет вообще никаких мыслей, как такое реализовать .
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
как бы в формуле формируется данный массив
Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(A1;;;СТРОКА(A1:A5);)))
Лень двигатель прогресса, доказано!!!
 
Цитата
Сергей написал:
в формуле формируется данный массив
Именно это и нужно. Спасибо Сергей
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
да пожалста грех кошакам не помочь  :D  
Лень двигатель прогресса, доказано!!!
 
Цитата
Сергей написал:
грех кошакам не помочь  

:D Судя по фотографиям в теме О погоде, Вы больше собак любите.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
пофлудим
дома так же имеется кошка и попугай  :)  
Лень двигатель прогресса, доказано!!!
 
Припоминаю, что относительно недавно была похожая тема. Если не ошибаюсь, одно из решений предложил БМВ. Использовал функции МУМНОЖ, ТРАНСП. Кручу, верчу и ничего не получается. Михаил, отзовитесь :)  
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
А в чем проблема? Сергей не помог?
 
vikttur, проблемы никакой нет. Сергей помог. Просто хочу увидеть еще варианты, если они есть.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Уррра, заработала :) :
=МУМНОЖ(--(СТРОКА(A1:A5)>=ТРАНСП(СТРОКА(A1:A5)));A1:A5)
Вдруг кому пригодится.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Bema, главное вовремя отозваться :-) .
Страницы: 1
Читают тему (гостей: 2)
Наверх