Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формула выдачи результата в одной ячейке при изменении условий в других
 
Во вложении файл. В желтые ячейки ставим цифровое количество. В столбце АК разные тексты. Подскажите, пожалуйста, формулу для ячейки B1, чтобы в ней отображался нужный текст из АК (крайне нежелательно ВПР). Примечание: нужный текст построчно связан с заполнением количества в желтом столбце. Спасибо.
 
Евгений И., чет не понятно а что там должно быть? как определить!?
 
Если заполены, к примеру, С3 и С17 - что отображать?
Возможно. объединять тексты...
=ПСТР(ЕСЛИ(СЧЁТ(C3:C13);СИМВОЛ(10)&AK3;"")&ЕСЛИ(СЧЁТ(C14:C27);СИМВОЛ(10)&AK14;"")&ЕСЛИ(СЧЁТ(C28:C37);СИМВОЛ(10)&AK28;"");2;9999)
 
Цитата
Евгений И. написал:
Примечание: нужный текст построчно связан с заполнением количества в желтом столбце

Поясните пожалуйста, это так:
  • от 1 до 20 - 1 текст
  • от 21 до 50 - 2 текст
  • от 51 до 100 - 3 текст
или как-то иначе?

Если так, то может функцией ЕСЛИ(И()) ?
No crime is so great as daring to Excel. (Winston Churchill)
 
Цитата
vikttur написал:
Если заполены, к примеру, С3 и С17 - что отображать?
С3 - текст из AK3
C17 - текст из AK14
То есть построчная зависимость нужного текста в зависимости от заполняемого диапазона
 
Цитата
Евгений И. написал: построчная зависимость нужного текста
Вы не ответили на вопрос: если заполнено ДВЕ ячейки ДВУХ диапазонов (С3 и С17) - что тогда?
Формулу для объединения текстов показал выше.
 
Изменено: Maruf - 7 Дек 2018 14:13:19
No crime is so great as daring to Excel. (Winston Churchill)
 
Цитата
vikttur написал: если заполнено ДВЕ ячейки ДВУХ диапазонов (С3 и С17) - что тогда?
То должно отображаться последнее "заполнение" (текст)
 
=ЕСЛИ(счет(нижний _диапазон);нижний_текст;ЕСЛИ(счет(ср _диап);ср_т;ЕСЛИ(счет(верх _диап);верх_т;"")))
Страницы: 1
Читают тему (гостей: 1)
Наверх