Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
[ Закрыто ] Поиск уникальных значений в разрезе месяца, оптимизация быстродействия формулы
 
Антиспам заблокировал собщение.

СУММПРОИЗВ с функциями внутри и с такими диапазонами строк ($C$2:$C$83974) - и Вы хотите быстрых вычислений?
Цитата
так и не смог дождаться конца подсчета, при заполнении всей таблицы отчета.
Не подумали, что и другие будут вынуждены ждать окончания пересчетов?
Попробуйте еще раз, но без ссылок. Прикрепите небольшой файл-пример.
 
Подумал, во вложении файл с диапазоном до 50 строк и формула только в 2х ячейках.
Написал 90 тыс. только в тексте сообщения.
 
Цитата
vikttur написал:
Не подумали, что и другие будут вынуждены ждать окончания пересчетов?Попробуйте еще раз, но без ссылок. Прикрепите небольшой файл-пример.
Подумал, во вложении файл с диапазоном до 50 строк и формула только в 2х ячейках.
Написал 90 тыс. только в тексте сообщения.
 
rediExcel, а зачем Вы дублируете свои сообщения?
 
И без цитаты понятно, на что отвечаете.
Вы бы лучше описали задачу и приложили файл... сообщение ведь скрыто.
 
Здравствуйте!
Ув. знатоки, необходима помощь в поиске более производительного (быстродействующего решения):
Имеется массив данных с инфо о посылках (лист "Послки_Данные" A1:D83974) из него необходимо заполнить информацию о количестве уникальных клиентов в рамках месяца (лист "Клиенты_отчет" Таблица 1 и Таблица 2).

В случае использования формул в B5 и B23 лист "Клиенты_отчет" с указанием всего диапазона исходных данных (которых в будущем может быть больше):
Код
=СУММПРОИЗВ((Послки_Данные!$C$2:$C$83974=$A5&B$4)/СЧЁТЕСЛИ(Послки_Данные!$D$2:$D$83974;Послки_Данные!$D$2:$D$83974))
=СУММПРОИЗВ((Послки_Данные!$C$2:$C$83974=B$22&$A23)/СЧЁТЕСЛИ(Послки_Данные!$D$2:$D$83974;Послки_Данные!$D$2:$D$83974))

так и не смог дождаться конца подсчета, при заполнении всей таблицы отчета.

какие есть варианты с более высокой скоростью работы?
 
Цитата
Юрий М написал:
зачем Вы дублируете свои сообщения?
Страницы: 1
Читают тему (гостей: 3)
Наверх