Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Найти если в тексте содержится
 
Всем привет.
Пользуюсь данной формулой
Код
=ЕСЛИОШИБКА(ИНДЕКС(ЛИСТ!G:G;НАИМЕНЬШИЙ(ЕСЛИ(ЛИСТ!$I$2:$I$2000="часть слова";СТРОКА(ЛИСТ!$A$2:$A$2000));СТРОКА(N1)));"")

Мне нужно допилить данную формулу которая выводит списком только если часть слова полностью совпадает. Но мне необходимо чтобы выводило список строк которые содержать часть букв или слов! спасибо...
 
=ПОИСК()
=НАЙТИ()
 
Файл-пример. Как есть - Как надо
Согласие есть продукт при полном непротивлении сторон.
 
Вот для примера
Посмотрите пожалуйста
 
фм
Код
=ЕСЛИОШИБКА(ИНДЕКС(ЛИСТ!G:G;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК("прим";ЛИСТ!$J$2:$J$2000));СТРОКА(ЛИСТ!$A$2:$A$2000));СТРОКА(B1)));"")
Изменено: artyrH - 13 дек 2018 09:36:52
 
Судя по расширению файла макросы в нем используются? Тогда проще.
UDF. Тоже вводится как формула массива
Код
Function ИНДЕКСНЕТОЧН(rngCond As Range, iCond As String, Optional rngVal As Range)
Dim arr1(), arr2(), iArr(), I&, J&
ReDim iArr(Application.Caller.Rows.Count, 0)
If rngVal Is Nothing Then Set rngVal = rngCond
arr1 = rngCond.Value
arr2 = rngVal.Value
For I = 1 To UBound(arr1)
    If arr1(I, 1) Like iCond Then
        iArr(J, 0) = arr2(I, 1)
        J = J + 1
    End If
Next
ИНДЕКСНЕТОЧН = iArr
End Function

 
Изменено: Sanja - 12 дек 2018 09:16:39
Согласие есть продукт при полном непротивлении сторон.
 
artyrH, большое спасибо! помогло!
Страницы: 1
Читают тему (гостей: 1)
Наверх