Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вывести строки со знаком @, Из ячейки нужно вывести строку с почтой
 
Имееются ячейки внутри которых до 10 строк, нужно вывести в другую ячейку строки где упоминается знак @
 
Правила: файл-пример.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
зачем файл ? Просто в А1:А10 содержатся ячейки внутри ячейки есть строка1-строка10 в одной из строк содержится почта - нужно ловить эту почту в ячейку В2
 
zamunyk, вставьте формулу, которую я нарисовал в Вашем примере, в соседний столбец

Цитата
vikttur написал: вывести в другую ячейку строки...
в одной из строк содержится почта
Никакого несоотвестствия не видите?
 
Цитата
zamunyk написал: зачем файл ?
зачем помощь ?

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
Цитата
zamunyk написал: зачем файл ?
Да потому как вы, по привычке, забываете упомянуть, что у вас гуглодоковское пристрастие - а там свои заморочки.
А по поводу примера - говаривают старики "Хлеб за брюхом не ходит"... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
https://docs.google.com/spreadsheets/d/1k-vqjLHXRrelBFr3jZ0nI7VFepePUzLaLpd6Tj5l0Ks/edit#gid=0[QUOTE]

зачем показывать формулу, которая вообще не то считаети Вы это сами видите? [МОДЕРАТОР]
 
zamunyk, Вы на форуме по Excel. Хотите быстрой и адекватной помощи - найдите, наконец, возможность прикреплять примеры в Excel

В Вашей теме Вам показывали решения в Excel, Вы написали, что разобрались - значит, есть возможность работать с Excel?
 
Ну там на странице с гуглом есть кнопка скачать как xlsx,  вот пожалуйста
 
Ну да... Вам помощь, так еще и по ссылкам бегать и файлы качать...  А могли получить помощь еще 2,5 часа тому.
Не нужно лениться, а приложить максимум усилий для получения помощи.

=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(A2;СИМВОЛ(10);ПОВТОР(" ";99));ПОИСК("@";ПОДСТАВИТЬ(A2;СИМВОЛ(10);ПОВТОР(" ";99)))-50;99));"")
 
с помощью PQ
Изменено: Anton555 - 14 Дек 2018 20:42:01
 
Почему то не ищет - если меняю почты в ячейках
 
Надо показывать, где не ищет.
 
воть
 
На первой позиции тоже может быть?
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(СИМВОЛ(10)&D3;СИМВОЛ(10);ПОВТОР(" ";99));ПОИСК("@";ПОДСТАВИТЬ(СИМВОЛ(10)&D3;СИМВОЛ(10);ПОВТОР(" ";99)))-50;99));"")
 
Доброе время суток.
Коли это для Google Spreadsheet так может просто примитивненько Udf функцией?
Код
function GetMail(fromText) {
  const reg = /[a-z$\.\$\d]+@[a-z$\.\$\d]+/i;
  return fromText.match(reg);
}
 
Спасибо, помогло
Страницы: 1
Читают тему (гостей: 1)
Наверх