Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет по листам и результаты на отдельном листе с названиями листов
 
Добрый вечер форумчане.
Вы мне очень помогли. Есть простенький вопрос.

В листе 1, 2 есть столбец с числами. Надо в листе №3 посчитать среднеарифметическое из каждого листа и написать результат рядом с название соответствующего листа.
 
в C3
Код
=СУММ(ДВССЫЛ(ПОДСТАВИТЬ(B3;" ";"")&"!B2:B11"))/8
или
=СРЗНАЧ(ДВССЫЛ(ПОДСТАВИТЬ(B3;" ";"")&"!B2:B11"))
 
Все работает. Но столкнулся со следующей проблемой. Если название листа 1 сделать на английском из двух слов(work well), формула не видит данную страницу. Пишет #ссылка
 
в примере покажите
и, раз у вас такой аватар, не пишите "столкнулся". пишите "столкнулась"
Изменено: artyrH - 22 дек 2018 21:32:05
 
Цитата
artyrH написал:
в примере покажите
название листа "wash am"
 
Цитата
prog_excel написал:
формула не видит данную страницу
у меня тоже не видит. такое имя "Wash_am" видит, с пробелом не видит. может кто и знает причину
 
Добавьте одинарные кавычки перед и после имени листа и проблемы не будет.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
Имя в одиночные кавычки
 
Код
=МАКС(ЕСЛИОШИБКА(СРЗНАЧ(ДВССЫЛ("'"&B3&"'!B2:B11")););ЕСЛИОШИБКА(СРЗНАЧ(ДВССЫЛ("'"&ПОДСТАВИТЬ(B3;" ";)&"'!B2:B11"));))
Цитата
artyrH написал:
у меня тоже не видит
все дело в '
Изменено: Catboyun - 22 дек 2018 22:16:26 (формула была не доработана, изменил)
 
спасибо
 
формулу в сооб. выше изменил (апнул на случай скачивания файла, до редактирования)
а лучше так
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(СРЗНАЧ(ДВССЫЛ("'"&B3&"'!B2:B11"));СРЗНАЧ(ДВССЫЛ("'"&ПОДСТАВИТЬ(B3;" ";)&"'!B2:B11")));"")
на случай отрицательных,
а еще лучше все же имена листов в ячейке писать в точном соответствии
Изменено: Catboyun - 22 дек 2018 22:25:17
 
Цитата
Catboyun написал:
формулу изменил (апнул на случай скачивания файла, до редактирования)
Огромное спасибо.
Первый вариант работает.
названия листов и ячеек совпадает. Прежде всего начал проверять это.
Изменено: prog_excel - 22 дек 2018 22:28:55
 
Цитата
prog_excel написал:
Первый вариант работает
не совсем, если убрать пробел в ячейке.
лучше используйте последнюю из #11
Страницы: 1
Читают тему (гостей: 1)
Наверх