Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сортировка столбца с числовыми данными по убыванию, и одновременная сортировка название в соседнем столбце.
 
Добрый вечер.
Есть два столбца. В первом числовые данные, во втором названия. Необходимо отсортировать по убыванию числовые данные, а названия также должны остаться в соответствие с числовыми данными до сортировка.
Использовал две формулы. Но почему то появляется ошибка "#число!" в последней строке.
В чем может быть дело?
Код
=НАИБОЛЬШИЙ(B:B;СТРОКА()-1)
=ВПР(D:D;B:C;2;ЛОЖЬ)
 
попробуйте так
Код
=НАИБОЛЬШИЙ(B:B;СТРОКА()-2)
или
=НАИБОЛЬШИЙ(B:B;СТРОКА(A1))
и
=ВПР(D3;B:C;2;0)

хотя, впр и так работает
 
Данные, однако, начинаются с 3 строки, а потому - вариант -
Код
=НАИБОЛЬШИЙ(B:B;СТРОКА()-2)
ps Обычная сортировка по выделенному/ым полю/полям тоже не возбраняется.
Изменено: Z - 23 Дек 2018 20:08:02
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Цитата
artyrH написал:
хотя, впр и так работает
ОК. А то не мог понять в чем дело.
Цитата
Z написал:
ps Обычная сортировка по выделенному/ым полю/полям тоже не возбраняется.
Хочется автоматическую.
 
artyrH, обнаружил следующую ошибку. Если есть два одинаковых числа, то формула забирает и повторяет только  одно название, соответствующее этому числу.

дано:
5 ябылко
5 груша

результат:
5 яблыко
5 яблыко

Все это видно файле.
Изменено: prog_excel - 24 Дек 2018 12:16:29
 
Цитата
prog_excel написал:
Но почему то появляется ошибка "#число!" в последней строке.В чем может быть дело?
мое решение исключало эту ошибку.
Цитата
prog_excel написал:
обнаружил следующую ошибку
это не ошибка. формулы правильно работают.
Страницы: 1
Читают тему (гостей: 1)
Наверх