Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
ВПР 2D некорректные результаты
 
ДД!
Помогите, пожалуйста, понять, что не так с формулой или она вообще не та? Вроде бы все по инструкции и должно работать, но значения подтягиваются некорректные.
Заранее благодарю!
 
Надежда,

Просто поменяйте местами 2 и 3 параметры:
Код
=ИНДЕКС(Цены;ПОИСКПОЗ(A3;товары_столбец;0);ПОИСКПОЗ($B$1;клиенты_строка;0))
 
Не совсем понял, что Вам нужно. Но формула считает ровно то, что Вы ее попросили.
Советую пользоваться встроенным инструментом "Вычислить формулу" на вкладке "Формулы" - сразу будет все понятно
 
Aleksei_Zhigulin, xм ))) Спасибо большое! И правда, не все по инструкции было. Почему-то ориентировалась на описание формулы индекс (массив;номер строки;номер столбца)

Еще раз благодарю.  
 
Цитата
Надежда написал:
не все по инструкции было.
воспользуйтесь советом, я сам прибегаю регулярно  
 
Цитата
Надежда написал:
Почему-то ориентировалась на описание формулы индекс (массив;номер строки;номер столбца)
Правильно ориентировались. Просто номер строки ищется в имени товары_столбец, а номер столбца - в имени клиенты_строка.
 
Цитата
Александр написал:
воспользуйтесь советом, я сам прибегаю регулярно
Уже все поправила, заработало ))
 
Еще вариант:
=ВПР(A3;'Действующий прайс'!$A$2:$K$11;ПОИСКПОЗ(B$1;'Действующий прайс'!$1:$1;0);0)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
Aleksei_Zhigulin написал:...товары_столбец...клиенты_строка.
Вот  когда жирненьким, совсем понятно стало  :D  Логично ведь на самом деле  :oops:  Спасибо большое!
Страницы: 1
Читают тему (гостей: 1)
Наверх