Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск значения по трем параметрам
 
Доброго времени суток.
Есть таблица, в которой отмечается наличие или отсутствие интересующего товара в торговой точке (1 - в наличии, 0 - нет в наличии). Так же есть 3 таблицы с разными адресами и различным ассортиментом, к тому же учет наличия товара ведется по неделям (10я неделя, 11я, и т.д.) Требуется по 3м критериям (адрес, товар и неделя) в сводную добавить данные по наличию.
Подскажите пожалуйста, как построить формулу, сама додумалась до этого, а дальше никак:
Код
=ИНДЕКС('Данные 1'!B2:G2&'Данные 2'!B2:G2&'Данные 2'!B2:G2;ПОИСКПОЗ(Сводная!B1&'Данные 1'!B1&'Данные 2'!B1&'Данные 3'!;

Пример во вложении.

Спасибо.
 
Добрый вечер!
вариант на PQ
 
Доброе время суток.
Ещё вариант.
 
Можно и формулой, но при добавлении/убирании листов - формулы нужно будет корректировать. Ваш способ хранения данных - не оптимальный для дальнейшей обработки. И PQ от Anton555 - лучшее решение, чем формулами от Михаил Лебедев. С Наступающим НГ!
Страницы: 1
Читают тему (гостей: 1)
Наверх