Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Разделить название книги и автора
 
Добрый день! Нужен хелп:
1. есть список купленных мною книг, который мне скинул интернет-магазин. Список представлен в формате  автор через слэш  название книги(или наоборот)
2. хочу удалить/скопировать только название книг и оставить в одной колонке, а автора - в другой.
3. я думал сделать следующим образом:
а) удалить все после слеша
б) удалить через ctrl-h слеш
с) таким образом останется только автор
д) повторить тоже самое, только до слеша
Вопрос: какая формула для а) и д)

Файл прикрепил

Спасибо
Вениамин
 
Примените стандартный инструмент "Текст по столбцам"
 
автор в В2 и растянуть вниз
Код
=ЕСЛИОШИБКА(ЛЕВСИМВ(A2;ПОИСК("/";A2)-1);"")
название в С2  и растянуть вниз
Код
=СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(A2;"/";ПОВТОР(" ";50));50))
Лень двигатель прогресса, доказано!!!
 
Сергей, в таких формула надежнее использовать сто пробелов. Имхо.
 
1. Заменить " / " на "/" (без кавычек)
2. Данные - Текст по столбцам - с разделителями - другой:/
 
Добрый день.

Вариант во вложении.
 
Казанский, А зачем этот пробел убирать?
 
Михаил С., ну некрасиво же, когда остается пробел в начале или в конце строки :) Потом могут быть проблемы с поиском, сортировкой и т.п.

Щас Кузя на регэкспе наваяет :D
 
Одна протягиваемая формула на оба столбца:
=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($A2;"/";ПОВТОР(" ";100));(СТОЛБЕЦ(A2)-1)*100+1;СТОЛБЕЦ(A2)*100))
Но я бы текст по столбцам использовал.
Изменено: Михаил С. - 11 Янв 2019 21:55:04
 
вариант функции
Код
Function bb(t$, Optional i& = 0)
 With CreateObject("VBScript.RegExp"): .Pattern = "[^/]+": .Global = True
  If InStrRev(t, "/") Then bb = Trim(.Execute(t)(i)) Else bb = t
 End With
End Function
n
Изменено: кузя1972 - 11 Янв 2019 14:16:14
 
Цитата
Сергей написал:
автор в В2 и растянуть внизКод ? 1=ЕСЛИОШИБКА(ЛЕВСИМВ(A2;ПОИСК("/";A2)-1);"")название в С2  и растянуть внизКод ? 1=СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(A2;"/";ПОВТОР(" ";50));50))


Лень двигатель прогресса, доказано!!!
спасибо! Понял суть формул!
 
А бездумно цитировать зачем?
 
Цитата
кузя1972 написал:
вариант функцииКод ? 12345Function bb(t$, Optional i& = 0) With CreateObject("VBScript.RegExp"): .Pattern = "[^/]+": .Global = True  If InStrRev(t, "/") Then bb = Trim(.Execute(t)(i)) Else bb = t End WithEnd Functionn
С позиции решение конкретно поставленной задачи - спасибо за решение. В следующий раз я точно не смогу сделать схожее :)
За файл с решением - огромное спасибо
 
Цитата
Казанский написал:
1. Заменить " / " на "/" (без кавычек)2. Данные - Текст по столбцам - с разделителями - другой:/
Спасибо большое. Познакомился с новой формулой :)
 
Цитата
Гаубица написал:

Спасибо большое!
 
Спасибо Всем! Задача решена! :)
 
Veniamin, цитируете - не думаете. Создаете сообщения - не думаете!
Цитата - это не бездумное копирование!
Нужно сначала ПОЛНОСТЬЮ прочитать все сообщения, после этого ответить одним сообщением. Если же не сообразили сразу - дополнить. А то создается впечатление, что руки работают быстрее головы.
Страницы: 1
Читают тему (гостей: 2)
Наверх