Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Получение значения из таблицы по заданному ключу или номеру строки.
 
Здравствуйте. Искал решение на форуме, не нашёл.
Подробное, надеюсь, описание задачи, есть в самом прилагаемом файле, как и примеры решения без формул - прямым указанием нужных ячеек.
Есть столбцы C и D с параметрами x,y. В эти столбцах мною уже прописана на всех 360 нужных строках ниже нужная формула, но она берёт данные из группы последовательных столбцов (2).



Есть группа последовательных столбцов (1), с "метками". И есть группа столбцов (2), в которых нужно, ориентируясь на значения из (1) (числа 1-7 там и тут), подставить ссылки на нужные ячейки с помощью формул или макроса (чтобы можно было протянуть вниз или нажать, и было заполнение до низа, т.е. до последней ячейки из столбца A со значением).

Числа 1-4 используют фиксированные метки на ячейки (через соотвествие символов в столбцах C,D и (1).
С числами 5-7 сложнее, они должны посдтавлять плавающее значение ячейки, берущееся из столбцов C,D и отличающееся номером строки на 1,2 или 3 (в соотвествии с метками в (1) вверх.  
Изменено: Рустем Галиев - 10 Фев 2019 18:40:49
 
Название однозначно придется поменять - ничего здесь массового нет. Просто получение значения из таблицы по заданному ключу или номеру строки.
Для чисел 1-4 используйте (пример для числа 1,x в строке 14)
Код
=ИНДЕКС($C$3:$C$9;ПОИСКПОЗ($J14;$B$3:$B$9;0))
для 5-7 (пример для числа 5,x в той же строке)
Код
=ИНДЕКС(C$1:C$369;СТРОКА()-$N14)
 
Рустем Галиев, у вас в 19 строке ошибка
Формулы две. Первая для букв, вторая для смещения
Код
=ВПР(ИНДЕКС($J10:$M10;СТОЛБЕЦ(B1)/2);$B$3:$D$6;ОСТАТ(СТОЛБЕЦ(B1);2)+2;)
=ИНДЕКС($C7:$D9;4-ИНДЕКС($N10:$P10;СТОЛБЕЦ(B1)/2);ОСТАТ(СТОЛБЕЦ(B1);2)+1)
Изменено: АlехМ - 10 Фев 2019 20:19:19
Алексей М.
 
Спасибо ответившим, особенно АlехМ за файл и указание ошибки, все работает.
Страницы: 1
Читают тему (гостей: 1)
Наверх