Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование ТОЛЬКО ячеек, содержащих определенный текст, Ломаю голову уже день, но не получается придти к решению
 
Добрый день, уважаемые форумчане. Возник вопрос следующего характера:
Есть строка, в которой в разных ячейках находится и обычный текст, и текст вида 4р, 8р, либо просто число. Необходимо сложить только те чейки из диапазона, в которых есть символ "р".

Пробовал всеми способами, что нашел в интернете, но либо ошибка либо в итоге получается 0.

Пример приложил
 
Формула массива:
=СУММ(--ЕСЛИ(ПРАВСИМВ(B2:O3)="р";ПОДСТАВИТЬ(B2:O3;"р";"");))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1
Читают тему (гостей: 1)
Наверх