Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выпадающий список зависимый от значения ячейки
 
Добрый день друзья. Наткнулся на ограничения в функции Проверка данных, не поддерживает длинные формулы. Как по другому сделать выпадающий список в ячейке G2 зависимым от значения в F2? В ячейку I2 просто вставил пример формулы. Спасибо.
 
 
Можно сделать макросом. Только нужно знать алгоритм формирования вып.списка.
P.S. В ячейке 'I2' никакой формулы нет
Согласие есть продукт при полном непротивлении сторон.
 
Сори, не тот пример. Обновил.
 
Попробуйте такую формулу для проверки данных:
=СМЕЩ(B1;ПОИСКПОЗ(E2;A1:A121;0)-1;;СЧЁТЕСЛИ(A:A;E2))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Меня, наверное, закидают тапками, но я бы сначала через VLOOKUP (ВПР) обратился бы к таблице, в первом столбце которой - ключи "ДуXX", а во второй - диапазоны данных в виде текста, например "A100:A110". А уже эти диапазоны преобразовывать в список через INDIRECT (ДВССЫЛ).
 
см.вложение
в диспетчере имен ДуД
Код
=ИНДЕКС(Лист2!C2;ПОИСКПОЗ(Лист2!RC[-1];Лист2!C1;)):ИНДЕКС(Лист2!C2;ПОИСКПОЗ(Лист2!RC[-1];Лист2!C1;)-1+СЧЁТЕСЛИ(Лист2!C1;Лист2!RC[-1]))
в проверке данных:
Список
=ДуД
..............
готово!
Изменено: Ігор Гончаренко - 27 Мар 2019 13:08:53
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
в диспетчер имен
Код
=ИНДЕКС(Лист2!$B$1:$B$2000;ПОИСКПОЗ(Лист2!e2;Лист2!$A$1:$A$2000;0)):ИНДЕКС(Лист2!$B$1:$B$2000;ПРОСМОТР(2;1/(Лист2!$A$1:$A$2000=Лист2!e2);СТРОКА(Лист2!$A$1:$A$2000)))
 
Спасибо всем за многочисленные варианты решения проблемы. Все работает на отлично.
Страницы: 1
Читают тему (гостей: 1)
Наверх