Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск суммы значений по массиву условий
 
Добрый день, Ув. Форумчане!

Тема не нова, но погуглив просторы интернета не нашел простого решения:
- имеется набор значений (чисел), каждому из которых соответствует артикул, и имеется набор артикулов, по которым необходимо найти сумму.
Функции СУММЕСЛИ и СУММЕСЛИМН удобны пока кол-во условий небольшое, но когда условий пара сотен начинаются проблемы.

Буду благодарен за любую помощь или совет.
 
названием темы урезали помощь. ;) СУММПРОИЗВ поможет точно.
 
Если не сложно, можете на моем примере показать использование СУММПРОИЗВ.
 
Alexey0185, Вам никто не подскажет по СУММПРОИЗВ: Вы сами ограничили помощь, обозначив в названии единственно возможный вариант решения.
Не нужно в названии указывать кажущийся Вам верным способ (функцию) - формулируйте ПРОБЛЕМУ.
 
Теперь понял сообщение V.
Я могу изменить название или нужно создавать новую тему?
 
Изменить не сможете. Предложите новое название - модераторы поменяют.
 
Благодарю.
Ув. модераторы, прошу изменить название темы на "Поиск суммы значений по массиву условий".
 
можно с доп столбцом и через суммесли по 1 критерию
Лень двигатель прогресса, доказано!!!
 
Вариант с доп. столбцами, к сожалению, мне не подойдет.
В оригинальном файле суммировать по массиву условий нужно будет порядка 50 столбцов.
 
По-моему, так...
Код
=СУММПРОИЗВ((СЧЁТЕСЛИ($D$2:$D$17;$A$2:$A$17)>0)*($B$2:$B$17))
проверяйте
===================
Если что, то автор вопроса выше предложил обобщенное название темы...
Изменено: IKor - 3 Апр 2019 11:56:41
 
Вариант:
=СУММПРОИЗВ(СУММЕСЛИ(A2:A17;D2:D7;B2:B17))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
IKor и Максим В. ОГРОМНОЕ спасибо!!!
Оба варианта работают.
 
у меня такой подход был. :)
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСКПОЗ(A2:A17;D2:D7;))*B2:B17)
Страницы: 1
Читают тему (гостей: 1)
Наверх