Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Макрос сортировки по дате в виде чч:мм:гг
 
Добрый день, подскажите пожалуйста, у меня имеется файл с данными где имеется ID номер, но у одного Ауди номера могут быть несколько строк с записями и мне нужно что бы с помощью макроса он выбирал самую новую запись.  
 
Добрый.
Не видя файла, как там расположены данные, что за данные (число ли там в формате время, или текст), в каких диапазонах предполагается сортировка, или тут дело не в сортировке, а в поиске самого "свежего" значения определенного ID (или Ауди? и может быть можно обойтись формулой, кто знает?) - иными словами без внятного файла-примера строк на 10-15 с пояснениями в стиле: "Отцы! у меня вот такой набор данных. Строк в наборе может быть сильно ниже колен. Как бы мне сделать так, что вот сюда ввожу вот это, а вот тут вижу сразу вот то?" - вряд ли быстро подскажем...
Кому решение нужно - тот пример и рисует.
 
Это конфидециальный файл поэтому не могу отправить. Щас на листочке нарисую и отправлю  
 
Такой пример
 
И вот из такого файла в колонке с датой нужно выбрать самое новое значение  
 
Впишите номер ID в ячейку в моем примере и увидите результат
 
Вариант на PQ - быстро и удобно (Data -> Refresh all)
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    Types = Table.TransformColumnTypes(Source,{{"Time", type time}}),
    Grp = Table.Group(Types, {"ID"}, {{"Maximum", each List.Max([Time]), type time}})
in
    Grp
 
Сейчас дойду до компа посмотрю. Спасибо заранее.
 
Можно вот такой формулой массива решить в ячейке G4
Код
=ЕСЛИ(F4<>"";ИНДЕКС(B2:B8;ПОИСКПОЗ(МАКС((B2:B8)*(A2:A8=F4));(B2:B8)*(A2:A8=F4);0);1);"")

Ввод формулы массива надо завершать сочетанием Ctrl+Shift+Enter.
Кому решение нужно - тот пример и рисует.
 
Код
=ПРОСМОТР(2;1/(A2:A8=F4);B2:B8)
если нет сортировки по дате то формула массива
=МАКС((A2:A8=F4)*B2:B8)

при чем здесь сортировка?
Изменено: V - 3 Апр 2019 17:51:17
Страницы: 1
Читают тему (гостей: 1)
Наверх