Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Условное форматирование ячейки на основании части данных самой ячейки, в ячейке объединенная информация из двух других
 
Всем добрый день.
Я на форуме новичок, прям дух, я бы сказал.
Есть небольшая задачка.
Имеется 2 таблицы на 2 разных листах с числовыми данными.
Во 2-ой таблице в одной ячейке содержится объединенная информация из двух ячеек 1-ой таблицы:
Каждая ячейка в таблице 2 имеет 2 строки (см. скрин):
Объединено это все формулой: =' ВЗНОСЫ'!Q4&СИМВОЛ(10)&' ВЗНОСЫ'!T4
Задача:
Задать условное форматирование ячейки в таблице 2, а именно закрасить ячейку цветом (неважно каким), на основании данных (больше или равно 0) второй строки этой же ячейки.

Также просьба подсказать, как исправить формат ячейки выделенной красным, т.к. уже все перерыл.
Вторая строка выводит числовое значение с 12 знаками после запятой, хотя таких чисел нигде нет, как нет и операций деления/умножения, чтобы такое число появилось. Формат везде задан одинаковый (числовой с 2-мя знаками после запятой).

Спасибо за помощь.
РК.jpg (120.54 КБ)
 
Сегодня что, бесплатный вход в картинную галерею? Что не тема то шедевр живописи!
 
kapsula, файлик дайте пжлста
Изменено: Wild.Godlike - 12 Апр 2019 13:07:57
 
Исправить "формат в обьедененной ячейке"
Код
=ТЕКСТ(E12;"# ##0,00")&СИМВОЛ(10)&ТЕКСТ(E12;"# ##0,00")

в УФ
Код
=--ПСТР(E13;ПОИСК(СИМВОЛ(10);E13)+1;99*99)

E13 - ячейка которую нужно залить
ну а Е12 данные для обьеденения соотв........


:)
Изменено: Ivan.kh - 12 Апр 2019 13:23:38
 
Ivan.kh, банально формулами, у меня красивше получилось
РК.jpg (64.89 КБ)
Лень двигатель прогресса, доказано!!!
 
Сергей, не понял немного, это сарказм? ;)
 
Ivan.kh, конечно  :D , тут народ картинками примеры шлет  
Лень двигатель прогресса, доказано!!!
 
Цитата
Сергей написал:
банально формулами
Ой Сергей, лукавите Вы. Почему границы поехали ;) ?
РК.jpg (67.2 КБ)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Максим В., рука дрогнула
Лень двигатель прогресса, доказано!!!
 
Wild.Godlike, и все-все.
Я очень прошу прощения, хотел сразу выложить пример из таблицы, но там массив большой и ячейки разбросаны.
Надо было сразу оформить пример...
Шутки и сарказмы понял, исправляюсь (пример во вложении).
Формула объединения ячеек содержится только в 1-ой строке 2-ой таблицы.
Спасибо
Изменено: kapsula - 12 Апр 2019 14:25:38
 
Цитата
kapsula написал:
как исправить формат ячейки
=ОКРУГЛ(Лист1!T3;2)&СИМВОЛ(10)&ОКРУГЛ(Лист1!W3;2)

УФ в файле.
Изменено: Wild.Godlike - 12 Апр 2019 14:31:51
 
Ivan.kh, спасибо, а то что в первой формуле первая и вторая ячейка имеют один адрес это нормально?

Wild.Godlike, благодарю, формула сработала. А не подскажете, почему может быть такой косяк?
Изменено: kapsula - 12 Апр 2019 14:29:31
 
kapsula, во всем виноват стандарт IEEE 754

А что это такое и с чем его едят) вам поможет гугл )
 
Цитата
kapsula написал:
а то что в первой формуле первая и вторая ячейка имеют один адрес это нормально?
нет, мне просто было лень это менять без файла, как я и писал
Цитата
Ivan.kh написал:
ну а Е12 данные для обьеденения соотв........
 
Wild.Godlike,  Спасибо. Понял.
По первой части с округлением все сработало, но вот с форматированием проблемы.
Форматирует только в один цвет (голубой) вне зависимости от значения второй строки в ячейке, кроме нуля, ноль не закрашивает.
Плюс диапазон только по одному столбцу, а нужно форматирование в диапазоне 2-ой таблицы B2:F19. Табличку обновил немного, на реальную больше схожа.
Немного условие поменялось: не "больше или равно", а просто "больше нуля" по второй строке ячейки.
Спасибо
Изменено: kapsula - 12 Апр 2019 16:44:52
 
один вопрос - одна тема
 
vikttur, я прошу прощения, но вопрос основной был про условное форматирование. Оно не работает
На второй вопрос я особо ответа не ожидал, но к сожалению вышло наоборот.
 
Тема и правда про УФ
=Лист1!W3>0
Не, ну конечно можно помудрить и отделить мух от котлет, то есть то что после перевода строки и сравнивать
=-MID(F2;FIND(CHAR(10);F2)+1;15)<0
, но есть ли смысл?
Изменено: БМВ - 12 Апр 2019 18:47:23
 
БМВ, огромное Вам спасибо.
Формула сработала, только пришлось перевести функции на русский:
Код
=-ПСТР(B2;ПОИСК(СИМВОЛ(10);B2)+1;15)<0

Смысл отделять мух как раз есть, т.к. в первой Вашей формуле все банальное и в то же время многовременизабирающее дело, т.к. кидать на каждую ячейку отдельную ссылку и УФ я за месяц не управлюсь, учитывая количество этих таблиц у меня.
А Ваша вторая формула сделал все как нужно.
Еще раз спасибо.
Изменено: kapsula - 15 Апр 2019 15:24:21
Страницы: 1
Читают тему (гостей: 1)
Наверх