Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Изменение даты циклом
 
Добрый день,
есть такая задача.

При записи процесса данные записываются 6 раз в сутки.
Нужно заполнить даты так, чтобы каждая 7 дата была на один день больше.
Как в файлике.
Не соображу, как это можно сделать формулой. Прошу совета.

Спасибо!
если где-то было-пардон, но поиском не нашел.
 
Вроде так  :) .
Наша суть отражается в наших повторяющихся действиях. Отсюда следует, что совершенство есть не действие, а привычка. Аристотель.
 
Добрый день! Подскажите как после 6 даты сделать пробел в строке, а каждая 7 дата была на один день больше!
 
Kenn23, не очень понял, что за пробел в строке. Такой что ли?
Наша суть отражается в наших повторяющихся действиях. Отсюда следует, что совершенство есть не действие, а привычка. Аристотель.
 
Вот так!
 
Код
=ЕСЛИ(ОСТАТ(СТРОКА();7);ЕСЛИ(C1="";МАКС($C$1:C1)+1;C1);"")
 
Kenn23,
Наша суть отражается в наших повторяющихся действиях. Отсюда следует, что совершенство есть не действие, а привычка. Аристотель.
 
Valo, спасибо большое! :)  
 
Valo, V, Спасибо большое за помощь! Всё работает!
 
Valo, еще один нубовский вопрос, а если первая дата стоит не в первой строке, а начинается со второй или третьей? как при этом сохранить цикл?
 
Chueoko,чуть поправил формулу, теперь можно с любой строки начинать :) .
Код
=ЕСЛИ(СЧЁТЕСЛИ(A$2:A3;A3)=6;A3+1;A3)
Наша суть отражается в наших повторяющихся действиях. Отсюда следует, что совершенство есть не действие, а привычка. Аристотель.
 
Chueoko, про какой цикл Вы говорите? И в названии темы упомянули про цикл...
 
Юрий М, цикл - в каждую седьмую строчку вносится дата следующего дня. С этим помогли, остался вопрос, как реализовать это, если даты заполняются не с первой строки (программу только-только осваиваю).  
Изменено: Chueoko - 17 Апр 2019 13:25:52
 
Нет тут никакого цикла.
 
Chueoko, в сообщении #11 все же работает :sceptic:  
Наша суть отражается в наших повторяющихся действиях. Отсюда следует, что совершенство есть не действие, а привычка. Аристотель.
 
Цитата
Valo,
да,все работает, спасибо!
Проглядел по старости лет)
:)  
Изменено: Chueoko - 25 Апр 2019 16:37:33
Страницы: 1
Читают тему (гостей: 1)
Наверх