Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
сумма значений столбцов, в зависимости от значения строки
 
Добрый день, помогите решить проблему:
Имеется таблица, горизонтальная ось - продукты и их стоимость, вертикальная - даты, значения дат - динамические, количество строк с одной датой может (и будет) меняться, количество строк может доходить до 2000 и, редко, более
Как подсчитать количество продуктов в строке, дата левого столбца которой, соответствует дате из выпадающего списка и если дат несколько?

НО самое главное, как записать ИТОГОВОЕ значения для каждой даты?

использовать макросы нельзя, умную таблицу тоже
ни индексом ни впр'ом, я, к сожалению, добиться нужного результата не смог
Изменено: Massacre - 25 Апр 2019 23:41:55
 
Massacre, привел вашу ячейку с выпадающим списком в нормальный вид (больше не делайте на объединенные ячейки выпадающий список формулы Вас не поймут)
Для вашей задачи подойдёт обычная =СУММЕСЛИ()
 
Большое спасибо, но я первоначально немного не правильно сформулировал вопрос, там самое важное это запись итогов каждого дня, извиняюсь за тупость
 
я очень тупой, спасибо большое, доперло
 
Цитата
Massacre написал:
запись итогов каждого дня
Не много не понял, что вы под этим подразумеваете?
Если брать ваш пример, то допустим вам нужен итог по 1 апреля в ячейке В10 формула =СУММ() вам разве не подойдёт?  
 
вот это
кстати, может знаете более изящное решение?
 
не знаю куда вам надо в какую ячейку попробуйте такую
Код
=СУММПРОИЗВ((($A$8:$A$22=L3)*$B$8:$K$22)*B7:K7)
Лень двигатель прогресса, доказано!!!
 
???
Страницы: 1
Читают тему (гостей: 1)
Наверх