Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Счет в диапазоне смешанных значений
 
Доброго здравия уважаемые Форумчане. прошу подсказать как можно сформировать список  из строки DT4:EG4 если в диапазоне DT6:EG20 появится значение. Сейчас использую формулу
Код
 =ИНДЕКС(Main!$DT$4:$EG$4;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ($L$2:L2;Main!$DT$4:$EG$4)=0)/(Main!$DT$8:$EG$8<>"");0);0))
, но работает только с восьмой строки. А у меня диапазон в котором могут появиться данные с шестой по двадцатую. Заранее благодарен
 
alex1210,к сожалению не понял из вашей формулы, чего вы хотели добиться.
давайте так, залейте еще один пример, без лишних листов. с исходными данными и с набором значений что должно из всего этого получиться.
и попробуем решить ваши пример.
 
alex1210, если правильно понял..сделал до строку .. выделил желтым
Код
=ИНДЕКС(ИНДЕКС(main!$DT$1:$EG$4;ПОИСКПОЗ(скважина!AR$4;main!$DS$1:$DS$4;0);1):ИНДЕКС(main!$DT$1:$EG$4;ПОИСКПОЗ(скважина!AR$4;main!$DS$1:$DS$4;0);14);ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ(скважина!AR$4:AR4;ИНДЕКС(main!$DT$1:$EG$4;ПОИСКПОЗ(скважина!AR$4;main!$DS$1:$DS$4;0);1):ИНДЕКС(main!$DT$1:$EG$4;ПОИСКПОЗ(скважина!AR$4;main!$DS$1:$DS$4;0);14))=0)/(main!$DT$5:$EG$5>0);0);0))

а еще обратите внимание что у вас скрытые символы в диапазоне DT6:EG20 и на будущее - удаляйте не нужные листы и данные что бы не искать где у вас что и на каком листе.

Перезалил файл и формулу изменил что бы немного динамичный была.

Изменено: Mershik - 29 Апр 2019 11:22:57
 
Mershik,доброго времени, к сожалению я видно плохо объяснил проблему, список формируется на листе скважина в колонке L из 4  строки листа main диапазон DT4:EG4. например если в диапазоне DT6:DT20 появляются данные то берем в список данные с ячейки DT4 (C6-3-1). Сейчас код формирует список если только в 8-й строке появляются данные. а надо чтобы он следил за диапазоном с 6 по двадцатую строку
 
alex1210, покажите в примере что должно получится.. удалите данные (часть данных) на листе main в строке 5 и посмотрите результат...
Изменено: Mershik - 29 Апр 2019 13:16:16
 
Загрузил, должен получиться список как в колонке L  листа скважина
 
alex1210, будьте добры, приложите усилия, покажите нормальный пример в котором отобразите ТОЛЬКО исходные данные и ТОЛЬКО желаемый результат и опишите что должно подтягиваться, а что вносится в ручную ..потому что у вас бардак - много лишней информации и не понятно что где и откуда...что нужно заполнят если все с 6 по 20 будут заполнены?
Изменено: Mershik - 29 Апр 2019 14:45:45
 
если будут заполнен диапазон DT6:EG20 то список сформируется со всей строки DT4:EG4
 
alex1210,  исключа.ться повторения если они есть в строке 4
Код
=ЕСЛИОШИБКА(ИНДЕКС(main!$DT$4:$EG$4;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ(скважина!$L$5:L5;main!$DT$4:$EG$4)=0)/(main!$DT$5:$EG$5>0);0);0));"")
Изменено: Mershik - 29 Апр 2019 15:21:55
 
Mershik,Спасибище огромное. Именно так он и должен работать
 
Mershik, скажите можно ли чем то заменить формулу счета непустых ячеек. дело в том что в рабочий документ код забрасывает данные с аксеса, ячейка пустая а эта формула все равно что то считает
Код
  =СЧЁТЕСЛИ(DT6:DT20;"<>"&"")
 
СЧЁТЗ() не подходит?
 
Юрий М, пробовал, все равно что то считает
 
Цитата
alex1210 написал:
пробовал, все равно что то считает
Попробуйте так:
Код
=СЧЁТЕСЛИ(DT6:DT20;"<>")
Изменено: Лунтик - 30 Апр 2019 13:58:30
 
alex1210, ну как вариант перед расчетом найти и заменить все скрытые символы с помощь. CTRL+H  скопировать ячейку со скрытым символом - вставить в найти и заменить на ничего
 
Лунтик,все равно учитывает
Mershik, Не получается, ищет только тот символ который в этой ячейке, и уменьшает на один только в этом столбце
 
Лунтик, Ваша формула и формула, показанная в файле автора - практически то же самое (только немного короче).

alex1210, такое бывает при копировании данных из других программ или после замены формул.
Пример:
=ЕСЛИ(A1=2;"";1)
При А1=2 вставим вместо формулы значение - ячейка не пустая, она содержит пустой текст (текст нулевой длины).
См. проверки в файле

Считайте так:
=СЧЁТЕСЛИ(A8:A20;"*?")
 
vikttur,Здравствуйте, подскажите, сейчас формула учитывает только ячейки, в которых два и более чисел, можно ли как то это исправить?
 
=СЧЁТ(1/A8:A20)
Вводится как формула массива.
Но правильно - привести дданные диапазона в нормальный вид, а не подставлять костыли.
 
А сейчас считает только если одно значение в ячейке, а их может быть в одной ячейке от  0 до 200
 
=СУММПРОИЗВ(--(ДЛСТР(A8:A20)>0))
 
УРААААААА! заработало. Спасибо огромное
Страницы: 1
Читают тему (гостей: 1)
Наверх