Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
При расчете суммы необходимо пропустить одну ячейку.
 
Добрый день. Подскажите как можно пропустить одну ячейку при расчете =СУММ(A1:G1) если значение нужно подставить через ячейку(H) в ячейку (I). пока никаких вариантов не нашел кроме как промежуточную ячейку (H) сделать строкой, а не числом. может есть еще какие либо варианты?
Изменено: Alien900 - 8 Май 2019 08:50:13
 
ни че не понятно в примере покажите
Лень двигатель прогресса, доказано!!!
 
покажите в примере как есть и как надо
 
Цитата
Alien900: как можно пропустить
например, создать доп. столбец-критерий (участвует/не участвует) и фильтровать по нему, вместо =СУММ() используя =Промежуточные.итоги()
Ну а если совсем "в лоб", то выделить диапазоны для суммирования через Ctrl, без того, который не нужен. Для вашего случая: =СУММ(A1:G1;I1)

Но, как уже и сказали, без файла-примера, гадать долго не будем   ;)
Изменено: Jack Famous - 8 Май 2019 10:15:56
Реквизиты для благодарностей — в профиле
 
=СУММ(A1:G1) - H1
из суммы исключена 1 ячейка (Н1)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Ігор Гончаренко,  :D
Реквизиты для благодарностей — в профиле
 
все так просто и красиво расписываете. но раз задал вопрос на форуме это не потому что думать не хочу. а потому что варианты решения спросил. кроме как промежуточную ячейку сделать строкой.
Пример во вложении.

P.S: Но если в друг потом потребуется эту пропущенную ячейку в другом месте считать. то строка уже не подойдет.
 
Цитата
Alien900: варианты решения спросил
и какой из предложенных не подходит и почему?…
Реквизиты для благодарностей — в профиле
 
Цитата
Alien900 написал:
но раз задал вопрос на форуме
ну... раз Вы задали и нет ответов - значит:
1. Вопрос настолько сложный, что местная публика не в состоянии на него ответить
2. Вопрос сформулирован настолько бестолково, что ответить на него не возможно (никто не понимает в чем, собственно, вопрос)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Alien900, Простите, но действительно не понятно, что вы хотите.
Цитата
Alien900 написал:
Подскажите как можно пропустить одну ячейку при расчете =СУММ(A1:G1) если значение нужно подставить через ячейку(H) в ячейку (I).
- уж что, что но у меня есть репутация дешифровщика загадочных хотелок, но это и мне не под силу. Пример бы более показательный, а то и там и там результат 7 из 7 , причем тут H - не понятно совсем.
По вопросам из тем форума, личку не читаю.
 
А тупо просуммировать нужные ячейки не судьба? Обязательно использовать диапазон?
Если автоматизировать бардак, то получится автоматизированный бардак.
Страницы: 1
Читают тему (гостей: 1)
Наверх