Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Переменная в FormulaLocal
 
Добрый день, уважаемые форумчане!

Пытаюсь выполнить расчеты в первой книге, использовав данные из второй книги с помощью FormulaLocal.
Сама формула выглядит так:
Код
=СУММЕСЛИ('[Книга1.xlsb]Лист1'!$I$2:$I$4492;N6;'[Книга1.xlsb]Лист1'!$Y$2:$Y$4492)
Думал объявить переменные следующим образом и использовать уже в FormulaLocal:
Код
Set Данные1 = Книга1.Лист1
Но не могу понять, записать эту переменную в FormulaLocal.
Если просто заменить [Книга1.xlsb]Лист1 на Данные1, то Excel повторно просит открыть книгу:
Код
=СУММЕСЛИ('Данные1'!$I$2:$I$4492;N6;'Данные1'!$Y$2:$Y$4492)
Подскажите, пожалуйста, как можно решить проблему?
Изменено: Leojse - 11 Май 2019 13:41:08
 
Код
Dim Данные1$
Данные1 = "'[Книга1.xlsb]Лист1'!"
Range("A1").FormulaLocal = "=СУММЕСЛИ(" & Данные1 & "$I$2:$I$4492;N6;" & Данные1 & "$Y$2:$Y$4492)"
Согласие есть продукт при полном непротивлении сторон.
 
Sanja, большое спасибо!
 
Sanja, подскажите, пожалуйста, еще.
А как сделать, чтобы жестко не привязываться к имени книги1?
Пробовал что-то типа:
Код
Данные1 = ThisWorkbook.Worksheets("Лист1")
но не получается
 
Код
Данные1 = "'[" & ThisWorkbook.Name & "]Лист1'!"
Согласие есть продукт при полном непротивлении сторон.
Страницы: 1
Читают тему (гостей: 1)
Наверх