Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вывод всех наименований по условию
 
Добрый день!

задача такая, ищу в таблице значение по нескольким другим, но совпадений может быть больше одного, а ПОИСКПОЗ + ИНДЕКС показывают первое найденное.
Как показать последующие, например с пом доп. ячейки с номером найденных значений.
Это первая задача.
Вторая вывески весь список найденных значений.

Пример прикреплен.

Помоги пожалуйста!
 
argyman, добрый день,  думаю  название темы не по феншую (правила форума) ... и в теме можно один вопрос ...
Изменено: Mershik - 22 Май 2019 11:16:58
 
Многоразовый ВПР
Согласие есть продукт при полном непротивлении сторон.
 
Mershik, спасибо за замечаний, мне нужно удалить тему и заново опубликовать?
 
Sanja, спасибо! этот прием для формулы массива подойдет? UPD. УПС. ПРОШУ ПРОЩЕНИЯ ГЛУПЫЙ ВОПРОС.
Изменено: argyman - 22 Май 2019 11:22:29
 
Цитата
argyman написал: этот прием для формулы массива подойдет?
Вы бы со статьей ознакомились, прежде чем такой вопрос задавать
Цитата

Ее надо ввести следующим образом:

  1. выделить ячейки, куда должны выводиться результаты (в нашем примере - это диапазон D6:D20)
  2. ввести (скопировать формулу в первую ячейку) диапазона
  3. нажать Ctrl + Shift + Enter
Согласие есть продукт при полном непротивлении сторон.
 
argyman, нет просто тут в тексте предложите для модераторов, что то  типа "Вывод всех наименований по условию" .Вариант Решения Вам уже предложил Sanja, а если будет норм название возможно еще вариантов подкинут, ребята тут талантливые.

Вариант:
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$3:B$7;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ(F$2:F2;B$3:B$7)=0)/(B$3:B$7<>"");0);0));"")
Изменено: Mershik - 22 Май 2019 15:18:15
 
Цитата
Mershik написал:
возможно еще вариантов подкинут
пользуясь случаем)) и сомневаясь в создании отдельной темы...

Ситуация похожая:
Собираюсь на лист2 загружать базу для проверки основного списка лист1.

В базе лист2 могут быть стрОки с пометкой "беда" или "победа" с абсолютно одинаковыми значениями строкИ.
Основной список лист1 содержит стрОки с критериями в единственном экземпляре, в отличии от листа2.


Задача состоит в том, чтобы игнорируя все значения "беда", мы вывели/показали только значение "победа", если таковое имеется, разумеется, для данных условий.


НО! Если значения "победа" нет вовсе, то было бы идеально вывести последнее(самое нижнее по строкам) значение "беда" для данного критерия(col1, col2...)

Дату показать было бы вообще идеально)

Заранее благодарю за помощь!




 
Не сомневайтесь. Создавайте тему с названием, отражающим Вашу задачу
Страницы: 1
Читают тему (гостей: 1)
Наверх