Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Не прописывает максимальную дату по при определенном критерии отбора
 
Прошу помочь в решении проблемы, в процессе работы потребовалось свести данные в одну таблицу с нескольких отчетов. Прочитав кучу материала в интернете, так и не нашел решение своей задачи (вернее нашел очень много но не один не работал), возможно у меня руки кривые или познания Excel совсем малы. Прошу помочь в решении проблема со получением даты последней записи по показателю, столбец выделил цветом, название "дата записи". Требуется наименование показателя который находится на листе  "лист1" "С2",  найти на листе "report3" в столбце "В" все строки с наименованием "С2" и вернуть в ячейку "лист1" "Н1" максимальное значение даты.
Изменено: qwerty159753 - 24 Май 2019 14:22:54
 
А если ввести формулу как формулу массива? ctrl+shift+enter
Результат верный?
Вот горшок пустой, он предмет простой...
 
Попробуйте формулу
Код
=МАКСЕСЛИ(Report3!$F$2:$F$233;Report3!$B$2:$B$233;Лист1!$C2)

Смотрите также здесь
https://www.planetaexcel.ru/forum/index.php?PAGE_NAME=message&FID=1&TID=97769&MID=808245#message808245
Изменено: IKor - 24 Май 2019 14:20:13
 
Цитата
PooHkrd написал:
А если ввести формулу как формулу массива? ctrl+shift+enterРезультат верный?
К сожалению нет, он выдает неверную дату, а так же появляются пропуски (пустые ячейки)
 
IKor, тему прочитал, функции данной у нас нет, если ввести формулу что Вы предложили, к сожалению результата нет (см. скриншот)
111111.png (14.94 КБ)
 
qwerty159753, то что вам пишут про формулу массива вам не о чем не говорит? если нет тогда забейте в поиск что такое формула массива и как она вводится
Лень двигатель прогресса, доказано!!!
 
Я вводил и так и так, спасибо за указание на неточность прикрепленного скриншота.
2222.png (12.26 КБ)
 
Цитата
qwerty159753 написал:
Я вводил и так и так
Если уж Вы "коверкаете" формулу, то следуйте хотя бы синтаксису функции ЕСЛИ()
Код
=МАКС(ЕСЛИ(Report3!$B$2:$B$233=Лист1!$C3;Report3!$F$2:$F$233;""))
формулу следует вводить как формулу-массива в первую ячейку, а затем копировать в оставшиеся целевые ячейки.

В качестве названия темы предлагаю: Поиск максимального значения по условию для неотсортированного массива данных или альтернатива функции МАКСЕСЛИ()
 
оно?
ааа.png (80.15 КБ)
Лень двигатель прогресса, доказано!!!
 
Сергей, да, прошу поделиться как сделали?
 
йцукен159753 массивная
Код
=ЕСЛИ(МАКС(ЕСЛИ((Report3!$B$2:$B$1000=C2);(Report3!$F$2:$F$1000)));МАКС(ЕСЛИ((Report3!$B$2:$B$1000=C2);(Report3!$F$2:$F$1000)));"")
Лень двигатель прогресса, доказано!!!
 
Спасибо.
Страницы: 1
Читают тему (гостей: 1)
Наверх