Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
подсчёт суммы кол-ва уникальных значений с промежуточным вычислением
 
Всем привет!

Есть таблица,
1.нужно посчитать количество уникальных значений,
2.умножить их на %,
3.далее округлить в верх
4.сложить уникальные значения

В примере все расписал
 
почему по данному значению P-547/1-016A5A-N стоит результат 4 а не 5 ?
если это ошибка то как вариант масивная мазута
Код
=СУММ(ОКРУГЛВВЕРХ(СЧЁТЕСЛИМН($C$2:$C$27;$C$2:$C$27;$A$2:$A$27;$A$2:$A$27)/100*$D$2:$D$27;0)*(ПОИСКПОЗ(ЕСЛИ($A$2:$A$27=L2;$C$2:$C$27);ЕСЛИ($A$2:$A$27=L2;$C$2:$C$27);0)=СТРОКА($A$2:$A$27)-1))-1
Лень двигатель прогресса, доказано!!!
 
Доброе время суток.
А смысл в пунктах 2 и 3, если по примеру достаточно посчитать для каждого номера линии количество уникальных клейм сварщиков? Если смысл есть, то тогда и пример приведите с его учётом.
 
да вы правы 5 а не 4, мозги кипят)))
 
Цитата
Андрей VG написал:
смысл в пунктах 2 и 3
смысл в том, что для каждого сварщика свой процент, и он зависит от количества сваренных стыков, конкретно в моём примере сварщик с клеймом 1HSH на линии P-547/1-016A5A-N отварил 12 стыков и по требованию контроль составит как минимум 2 стыка 12/100*10=1,2 округляем вверх =2, а по уникальным шифру и клейму получим 1
 
Сергей, спасибо всё работает, но, что не могу разобраться со второй половиной формулы, как понял первая часть сводит все значения уже под округление, но вот как вторая часть производит отбор, можете пояснить
Код
(ПОИСКПОЗ(ЕСЛИ($A$2:$A$27=L2;$C$2:$C$27);ЕСЛИ($A$2:$A$27=L2;$C$2:$C$27);0)=СТРОКА($A$2:$A$27)-1)
 
по если отсеиваем не нужные данные
Код
ПОИСКПОЗ({"67VL":"54А":"78К":"78К":"78К":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ};{"67VL":"54А":"78К":"78К":"78К":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":"1HSH":ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ};0)=СТРОКА($A$2:$A$27)-1)
далее поискпоз определяет позицию первого совпадения в массиве
Код
{1:2:3:3:3:6:6:6:6:6:6:6:6:6:6:6:6:18:18:18:18:18:18:18:18:18}=СТРОКА($A$2:$A$27)-1)
далее сравниваем с диапазоном позиций
Код
{1:2:3:3:3:6:6:6:6:6:6:6:6:6:6:6:6:18:18:18:18:18:18:18:18:18}={1:2:3:4:5:6:7:8:9:10:11:12:13:14:15:16:17:18:19:20:21:22:23:24:25:26}
и наконец сравнением определяем уникальные позиции первого совпадения
Код
{ИСТИНА:ИСТИНА:ИСТИНА:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ}
у а дальше математическая операция которая обнуляет ненужное
Лень двигатель прогресса, доказано!!!
 
Сергей, спасибо разберусь обязательно!
 
Посмотрите еще и такую формулу-массива
Код
=СУММ(ЕСЛИОШИБКА((($A$2:$A$27)=$L2)/СЧЁТЕСЛИМН($A$2:$A$27;$L2;$C$2:$C$27;$C$2:$C$27)*ОКРУГЛВВЕРХ(($D$2:$D$27)/100*СЧЁТЕСЛИМН($A$2:$A$27;$L2;$C$2:$C$27;$C$2:$C$27)/(($A$2:$A$27)=$L2);0);0))
Изменено: IKor - 28 Май 2019 17:47:18
Страницы: 1
Читают тему (гостей: 1)
Наверх