Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Проставить в столбцах В и С значения 1 при условии, что в столбце А есть соответствие названия столбцов.
 
Иногда при работе с базами требуется найти в ней какие-либо параметры и создать дополнительные условия.
Проставить в столбцах В и С значения 1 при условии, что в столбце А есть соответствие названия столбцов. Если же такого соответствия нет, то ставим 0.
НЕ переводите написанную Вами формулу в значение.

Как это сделать?
Screenshot_1.jpg (118.4 КБ)
 
функцией СЧЁТЕСЛИ
Нужно бежать со всех ног, чтобы только оставаться на месте, а чтобы куда-то попасть, надо бежать как минимум вдвое быстрее!
 
=--($A2=B$1)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Обе написанные функции работают, но как продублировать функцию СЧЕТЕСЛИ для остальных чтобы значение B1 не менялось.
И на фото 2 как выполнить функцию для подобной записи, если слово которое ищем одно из некоторых?
Screenshot_2.jpg (135.53 КБ)
Screenshot_3.jpg (145.65 КБ)
 
Прикрепите файл пример. По картинкам Вам вряд ли кто-то станет показывать.
Нужно бежать со всех ног, чтобы только оставаться на месте, а чтобы куда-то попасть, надо бежать как минимум вдвое быстрее!
 
Цитата
Dyroff написал:
вряд ли кто-то станет показывать.
да не жалко, 12alian12,  вставьте в картинку в нужное место "*"& &"*"
Лень двигатель прогресса, доказано!!!
 
Вот)
 
12alian12,
=ЕСЛИОШИБКА(ПОИСК("*"&B$1&"*";$A2);0)
Изменено: Wild.Godlike - 28 Май 2019 17:16:35
 
Как вариант
Код
=ЕСЛИОШИБКА(ЕСЛИ(ПОИСК(B$1;$A2;1)>=1;1;0);0)
Нужно бежать со всех ног, чтобы только оставаться на месте, а чтобы куда-то попасть, надо бежать как минимум вдвое быстрее!
 
Спасибо всем за помощь, вроде, уже ясно)
Страницы: 1
Читают тему (гостей: 1)
Наверх