Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Посчитать количество ячеек
 
Добрый день друзья! Подскажите как правильно написать формулу для подсчета ячеек, например есть столбец с номерами магазинов, далее есть столбец с количеством ассортимента и названием, в каждом магазине разное количество ассортимента перечисленного в строках с одного и до ...., как мне вывести отдельный столбец с номером магазинов и количества в нем ассортимента. В ручную сделать нереально, но есть база ексель. Магазинов более 100, ассортимента тысячи
Например магазин 22 количество в нем 10 и так далее
Пример во вложении
Изменено: GUDVIL - 30 Май 2019 09:27:38
 
Добрый и Вам. Пример покажите в файле Экспель. Как есть, какой результат нужен.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
без примера только предположения по функциям счетесли или суммесли
Лень двигатель прогресса, доказано!!!
 
сводная не подойдет?
ассортимент точно в числах?
Изменено: V - 30 Май 2019 09:33:15
 
Отбираем уникальные номера магазина формулой массива:
=ИНДЕКС($A$2:$A$40;ПОИСКПОЗ(;СЧЁТЕСЛИ($I$1:I1;$A$2:$A$40);0))
Считаем ассортимент:
=СЧЁТЕСЛИ($A$2:$A$40;I2)
А лучше всего построить сводную, как предложил V
Изменено: Максим В. - 30 Май 2019 09:41:18
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Спасибо большое, буду пробовать
Страницы: 1
Читают тему (гостей: 1)
Наверх