Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск текста в ячейке по ключевым словам
 
Всем привет!
Как можно изменить громоздкую формулу во вкладке Main, столбец BP?
Суть заключается в том, что формула ищет по вспомогательной таблице во вкладке Sup ищется определенная комбинация встречающихся текстов и после производится замена на текст в столбце А:А вкладки Sup.
Приведу пример:
Если в тексте встречается исключительно Ремонт -> то присваивается название Ремонт
Если в тексте встречается и Ремонт, и Установ -> то присваивается название Ремонт, Установка
Если в тексте встречается либо ревизи, либо провер, либо анализ, либо осмотр -> то присваивается название Ревизия
Если в тексте встречается и ревизи, и смаз -> то присваивается название Ревизия, Смазка
Формула работает, но она очень громоздкая и из-за нее висит файл с 50000+ строками, иногда даже просто не открывается
Файл-пример прикладываю, на скрытые столбцы внимания не обращать
Спасибо!
 
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sup!$A$57:$A$89;АГРЕГАТ(15;6;Sup!$F$57:$F$89/ЕТЕКСТ(Sup!$B$57:$E$89)/ЕЧИСЛО(ПОИСК(Sup!$B$57:$E$89;I2));1));$BQ$1)
 
dude, а как исключить ненужные варианты через запятую?
 
Вопрос не по теме
Страницы: 1
Читают тему (гостей: 1)
Наверх