Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование разное количество строк в одном столбце
 
Уважаемые пользователи !

Подскажите пожалуйста формулу, которая позволяет автоматически охватывать разное количество строк для суммирования. Пример во вложении (нужно охватить ячейки 3D:4D и  поставить сумму в серую ячейку 5D и так далее)

Заранее спасибо.  
 
Обычная СУММ. Протянуть формулу на весь столбец всё-равно не получится, т.к. у вас там константы


ps. Если этот список делается на основе листа с данными, то лучше использовать сводную таблицу с промежуточными итогами
Изменено: Dark1589 - 14 Июн 2019 12:02:41
 
Для доп. столбца:
=ЕСЛИ(C3="СУММА";B2;СЧЁТЕСЛИ($C$3:C3;"СУММА")+1)
Для суммы:
=ЕСЛИ(C3="СУММА";СУММЕСЛИ(B:B;B3;D:D);D3)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Всм спасибо за помощь. Вы мне очень помогли.
 
Вариант одной формулой:
=ЕСЛИ(C3="СУММА";СУММ($D$3:D3)-СУММЕСЛИ($C$2:C2;"СУММА";$F$2:F2);D3)
Изменено: Максим В. - 14 Июн 2019 14:02:11
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Максим, а можно последнюю формулу прописать в файле. Заранее спасибо.  
 
frankdrebin, добавил в 5-м сообщении
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Спасибо. Выручил.
Страницы: 1
Читают тему (гостей: 1)
Наверх