Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как избавиться от пробелов, образующихся при выгрузке из 1С?
 
Добрый день!
Проблема с ВПР -
Есть Данные - в таблице это Мастер-Файл.
На второй странице данные, скачанные из 1С - надо Подтянуть количество в Мастер-Файл.
Но данные не тянутся т.к. в "из 1С" в конце наименований присутствует РАЗНОЕ количество пробелов (НЕ Везде!).
Как удалить НЕНУЖНЫЕ пробелы? (Вручную не получится т.к. более 15 тыс. строк.)
=Спасибо=
 
Цитата
kolyale написал:
Проблема с ВПР
Цитата
kolyale написал:
Как удалить НЕНУЖНЫЕ пробелы?
Задача в чём, удалить пробелы, заставить работать ВПР, а может нужно посчитать определенны данные из выгрузки 1С? Так и нужно было назвать тему соответственно, при чем здесь ВПР? Предполагаю, что название "Подсчет значений при не полном совпадении наименований" более подходит.
Можно и с ВПР
Код
=ВПР(A2&"*";'из 1С'!A:B;2;0)

Но в выгрузке есть одинаковые наименования, строки 4-6, при ВПР подтянутся только данные строки 4, а как должно быть, вам виднее.

Изменено: gling - 14 Июн 2019 23:29:30
 
Ещё как вариант ищет по совпадению первых 78 символах (кол-во можно изменить), правда массивная
Код
=ИНДЕКС('из 1С'!$B$2:$B$27;ПОИСКПОЗ(ЛЕВСИМВ(ПОДСТАВИТЬ('Мастер-Файл'!A2;" ";"");78)&"*";ПОДСТАВИТЬ('из 1С'!$A$2:$A$27;" ";"");0))
 
В первую очередь - задача УДАЛИТЬ ненужные пробелы в конце. Т.к. 1С Так выгружает и ЭТО проблема. Сегодня мне нужно делать ВПР, а завтра другую функцию. В первую очередь нужно ПРИВЕСТИ Выгруженные данные в надлежащий вид, когда их сможет обрабатывать Любая Другая функция. Ну и Во-вторых, сделать корректный ВПР.
=Спасибо!=
 
СЖПРОБЕЛЫ
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
kolyale, название темы должно отражать проблему. Какую проблему решаете? Предложите новое название - модераторы поменяют.
 
Цитата
Ігор Гончаренко написал:
СЖПРОБЕЛЫ
- Отличная Функция, о существовании которой ч не подозревал... Большое СПАСИБО!
 
Цитата
kolyale написал: Проблемы с ВПР
Цитата
kolyale написал:  СЖПРОБЕЛЫ- Отличная Функция Большое СПАСИБО!
:D  :D  :D  
Согласие есть продукт при полном непротивлении сторон.
 
Кто теперь на очереди с нзванием темы? gling
 
название темы:
как избавиться от пробелов, образующихся при выгрузке из 1С
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Страницы: 1
Читают тему (гостей: 4)
Наверх