Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Группировка данных под один шаблон
 
Чесслово, пытался найти решение проблемы, настраиваемая сортировка не спасает. Суть в следующем, на листе 1 имеется две группы данных 1-я(столбцы с названием 1,2,3), 2-я 4,5,6, но в них названия  элементов расположены в хаотическом порядке, для наглядности сделал подобные, поменял только 2 и 3 строчку и во второй группе удалил 5 и 6 строчки , а в 1-ом отсек последние,
Как можно сгруппировать данные и привести к виду как на листе 2, так что бы, если нет элементов в одном столбце они все равно прописывались в виде пустых ячеек. Если за шаблон брать порядок элементов с листа 2.
Соответсвенно число редактируемых столбцов может доходить до 50 или 100, Заранее всем спасибо
Изменено: Arteeck - 14 Июн 2019 23:22:46
 
Вариант в файле, с использованием ИНДЕКС+ПОИСКПОЗ, два диапазона - две формулы.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B:$D;ПОИСКПОЗ($A2;Лист1!$A:$A;);ПОИСКПОЗ(B$1;Лист1!$B$1:$D$1;));"")
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$H:$J;ПОИСКПОЗ($A2;Лист1!$G:$G;);ПОИСКПОЗ(G$1;Лист1!$H$1:$J$1;));"")
Страницы: 1
Читают тему (гостей: 3)
Наверх