Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Количество определённых значений в группе (диапазоне)
 
Всем доброго времени суток! Очень надеюсь на Вашу помощь!

Необходимо посчитать количество цифр, а именно 3 (троек) и 5 (пятёрок) в столбце D. Результат вывести в первую строку столбца Е, которая соответствует группам из столбца С (отсортирован по возрастанию).
В столбце D - значения от 1 до 5. Может быть пусто, либо нет 3 и (или) 5, тогда вернуть значение 0.

Заранее спасибо! Файл с примером во вложении.
 
Код
=ЕСЛИ(C4=C3;"";СУММПРОИЗВ((C4:C99=C4)*((D4:D99=3)+(D4:D99=5))))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Ігор Гончаренко, кланяюсь в пол!
 
SUM(COUNTIFS(C4:C18;C4;D4:D18;{3;5}))
 
БМВ, спасибо! Формула возвращает верное значение в первую строку группировки! А в остальные нет. Её нужно немного доработать под эту задачу, но тем не менее спасибо!
 
koshilek,
добавьте ЕСЛИ, поставьте абсолютные ссылки
Код
=ЕСЛИ(C4=C3;"";СУММ(СЧЁТЕСЛИМН($C$4:$C$18;C4;$D$4:$D$18;{3;5})))

БМВ, Вам вариант на "подумать" предложил
 
Цитата
Stics написал:
на "подумать" предложил
- в самую точку, даже равно не поставил, видя формулу Игоря.
 
БМВ, я понял, но до такого я бы не "дошёл" сам. Спасибо!
Страницы: 1
Читают тему (гостей: 1)
Наверх