Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Найти минимальную сумму для повторяющегося номера, присвоить значение
 
Уважаемые знатоки Excel, прошу помочь поправить формулу.

Задача - если в столбце № есть повторяющиеся значения и сумма объемов этой строки = 0, необходимо присвоить "удалить из списка"

Сейчас формула работает правильно, если у повторяющегося номера, строка с суммой объемов > 0, находится выше строки с суммой = 0.      
Подскажите, пожалуйста, как скорректировать формулу, чтоб можно было обойтись без предварительной сортировки данных.

Спасибо!
Изменено: IrinaVN - 17 Июн 2019 00:32:50
 
Код
=ЕСЛИ(И(СУММ(RC[-4]:RC[-3];RC[-2]:RC[-1])=0;СЧЁТЕСЛИ(R2C2:RC[-6];RC[-6])>1);"удалить из списка";ЕСЛИ(RC[-7]=6;"удалить из списка";"актуальные значения"))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Ігор Гончаренко,

Спасибо за ответ.

не поняла, для чего в формуле поменяли стиль ссылок.  :(  
 
Цитата
IrinaVN написал:
без предварительной сортировки
Вариант
Код
=ЕСЛИ(И((СЧЁТЕСЛИ($B$2:$B$49;B2)-1)>0;СУММ(D2:G2)=0);"удалить из списка";"актуальные значения")
или так
=ЕСЛИ(И(СЧЁТЕСЛИ($B$2:$B$49;B2)>1;СУММ(D2:G2)=0);"удалить из списка";"актуальные значения")
Изменено: gling - 17 Июн 2019 00:41:47
 
gling, огромное спасибо, работает!
Страницы: 1
Читают тему (гостей: 1)
Наверх