Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Определить наличие показателя, Определить есть ли показатель по ФИО и по МесяцГод
 
Всем, добрый день! Подскажите пожалуйста можно ли формулой узнать есть ли у определенного человека за определенный МесяцГод Показатель?
Задача:
На листе "Показатели" в ячейку В1 заноситься "Месяц Год", например "Сентябрь 2018". Нужно, чтобы в колонке с С4:С9 Ексель определил у кого нет показателя2 на листе "Отчет" - это те, у кого показатель равен 0:00.

Меня интересует именно возможность не макросами, а формулой. Если есть такая формула то подскажите какая?
 
Виталий Криворучко, можно так в С4
Код
=ЕСЛИ(СЧЁТЕСЛИМН(Отчет!$A$2:$A$31;Показатели!$B$1;Отчет!$C$2:$C$31;Показатели!B4;Отчет!$E$2:$E$31;">"&0)=0;"Нет";"Есть")
 
Добрый день.
Можно в С4 вот такое:
Код
=ЕСЛИ(СУММПРОИЗВ(--(Отчет!$C$2:$C$31=Показатели!B4);--(Отчет!$A$2:$A$31=Показатели!$B$1);Отчет!$E$2:$E$31)>0;"да";"нет")

и растянуть вниз.
Кому решение нужно - тот пример и рисует.
 
Код
=СУММПРОИЗВ((Отчет!$A$2:$A$31=Показатели!A4)*(Отчет!$C$2:$C$31=Показатели!B4)*(Отчет!$E$2:$E$31=0))
В жизни нет ничего невозможного! Есть только недостаток знаний и умений.
 
О, большое спасибо! Сейчас буду разбираться с формулой. Отлично работает.
Страницы: 1
Читают тему (гостей: 1)
Наверх