Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Найти первое и последнее измерение в интервале дат
 
Доброго всем!
Столкнулся с задачкой:
Есть данные в двух столбцах. В первом столбце даты формата ДД.ММ.ГГГГ ЧЧ:ММ:СС. Данные не обязательно в возрастающем по времени порядке, количество замеров в каждые дни не одинаковы. Во втором столбце результаты замера.
Необходимо в массиве данных вычислить значение первого замера и последнего замера на определенную дату.
Можно решить множеством лишних телодвижений, но чувствуется есть какая то изящная формула массива для решения задачи (которую я никак не подберу).
Прошу Вашей помощи или подсказок.

P/S - Форум смотрел. Аналогичного вопроса не видел. Похожие темы не помогли справиться с вопросом
Изменено: moneta - 19 Июн 2019 18:09:27
 
См. вариант.
 
Код
=ИНДЕКС(B:B;1+ПОИСКПОЗ(МИН(ЕСЛИ($A$2:$A$565>=F2;ё$A$2:$A$565));$A$2:$A$565;))
=ИНДЕКС(B:B;1+ПОИСКПОЗ(МАКС(ЕСЛИ($A$2:$A$565<F2+1;$A$2:$A$565));$A$2:$A$565;))
Изменено: Ігор Гончаренко - 19 Июн 2019 19:57:51
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Юрий М, Ігор Гончаренко, Большое спасибо!
я почему то то про поиск позиции в последнюю очередь подумал.
Страницы: 1
Читают тему (гостей: 1)
Наверх